faire un tri par date

Mamiejo

XLDnaute Nouveau
J'ai fait des relevés avec des dates allant de 1650 à 2000. Dans la colonne j'inscris le jour le mois et l'année : ex: 15/02/1650 OU 31/12/2000;
Je n'arrive pas à faire un tri par date. Il n'y a que les dates de 2000 qui sont triées. Je possède Excel 2003. Je demande de l'aide pour finir ce travail.
Merci
Mamiejo
 

JCGL

XLDnaute Barbatruc
Re : faire un tri par date

Bonjour à tous,
Bienvenue sur XLD,

Pour Excel les dates commencent le 01/01/1900, ceci peut, peut être, expliqué cela...

Dépose ton fichier pour un tentative d'aide appropriée

Au plaisir de te lire
A+ à tous
 

hoerwind

XLDnaute Barbatruc
Re : faire un tri par date

Bonjour, salut JCGL,

Sans vouloir faire la pub pour d'autres tableurs, Calc (OOo) permet le calcul, donc aussi le tri, de dates antérieures à 1900 (limite Excel).

Vouloir le faire sur Excel me parait fort difficile, d'autant plus s'il faut tenir compte du passage du calendrier Julien au calendrier Grégorien (ce qui n'est pas le cas pour l'exemple donné).
 

hoerwind

XLDnaute Barbatruc
Re : faire un tri par date

Bonjour,

Le tri est faisable par une colonne intermédiaire qui additionne 2000 années à chaque valeur, qu'elle soit du texte ou une date.

Cette addition peut se faire par une seule formule.
Si tu ne vois pas comment faire, je te posterai un exemple.
 

JCGL

XLDnaute Barbatruc
Re : faire un tri par date

Bonjour à tous,

Un essai dans le fichier joint avec :
Code:
=SI(ESTNUM(A1);DATE(ANNEE(A1)+1900;MOIS(A1);JOUR(A1));(STXT(A1;1;6)&DROITE(A1;4)+1900)*1)
A+ à tous
 

Pièces jointes

  • JC Tri Date.xls
    13.5 KB · Affichages: 34

hoerwind

XLDnaute Barbatruc
Re : faire un tri par date

Salut JCGL,

Si j'avais proposé 2000, c'est qu'il y avait une raison.
Tous les 2000 ans, les années bissextiles sont les mêmes.
Exemple : les années 2000 et 4000 sont bissextiles, l'année 3900 ne l'est pas.
 

Discussions similaires

Réponses
9
Affichages
265
Réponses
12
Affichages
420
Réponses
28
Affichages
1 K

Statistiques des forums

Discussions
312 897
Messages
2 093 392
Membres
105 720
dernier inscrit
gumoreau