Etrendre une moyenne d'un groupe de valeurs fixes

ADNmt

XLDnaute Nouveau
Bonjour,

Voila mon petit soucis :
J'ai dans la colonne A, 25000 valeurs
Dans la colonne B, je cherche à faire les moyennes d'un groupe de 50 valeurs qui se suivent
Exemple B1 : =moy(A1:A50)

Je cherche à étendre une formule le long de la colonne B pour avoir :
B1 : =moy(A1:A50)
B2 : =moy(A51:A101)
B3 : =moy(A102:A152)
etc..

et non pas :
B1 : =moy(A1:A50)
B2 : =moy(A2:A51)
B3 : =moy(A3:A53)

Savez vous si il y a une formule qui me permet de faire cela ?
Un grand merci d'avance

Cordialement,
ADNmt
 

Efgé

XLDnaute Barbatruc
Re : Etrendre une moyenne d'un groupe de valeurs fixes

Bonjour ADNmt et bienvenu sur le forum.

Il est toujours préférabkle de fournir un petit fichier de test pour simplifier la tâche et vérifier les propositions.

Avec ce que j'ai compris, a mettre en B1 et à recopier vers le bas:
=MOYENNE(DECALER($A$1; (LIGNES($1:1)*50)-50;;50; ))

Cela va faire
=MOYENNE($A$1:$A50)
=MOYENNE($A$51:$A100)
=MOYENNE($A$101:$A$150)


Cordialement
 
Dernière édition:

renyeu

XLDnaute Occasionnel
Re : Etrendre une moyenne d'un groupe de valeurs fixes

Bonjour,
En pj une école parmi d'autres ;)
Cdlt
Renyeu
 

Pièces jointes

  • Classeur1.xlsx
    210.9 KB · Affichages: 32
  • Classeur1.xlsx
    210.9 KB · Affichages: 39
  • Classeur1.xlsx
    210.9 KB · Affichages: 32

Discussions similaires

Statistiques des forums

Discussions
313 274
Messages
2 096 754
Membres
106 739
dernier inscrit
jcdu16