XL 2019 Incrémenter une plage de cellules dans une formule lors d'une recopie.

Astyanax

XLDnaute Occasionnel
Bonjour,
j'ai un problème tout simple mais je ne sais pas comment le résoudre ni ne sais si cela est possible.
Je n'ai pas de fichier à joindre mais c'est facile à comprendre.

En colonne A (de A1 à A50) , j'ai des nombres de valeur inférieure à 20.
En colonne B, en B1 j'ai la formule suivante =moyenne(a1:a3)
en B2, la formule =moyenne(a4:a6) donc une incrémentation de 3 lignes de la plage de cellules.
J'aimerais faire une recopie de la formule pour la suite de la colonne B en incrémentant de 3
pour trouver en B3 =moyenne(a7:a9), en B4 =moyenne(a10:a12) ...

C'est pénible de modifier les valeurs pour chaque formule.
Cela est-il possible simplement ?

Merci de me répondre.
Bonne soirée.
 

Dranreb

XLDnaute Barbatruc
Bonsoir.
C'est à peu près (voire exactement ?) ça :
Code:
=MOYENNE(DECALER($A$1;3*(COLONNE()-2);0;3;1)
Edition : Non en relisant ça doit plutôt être :
Code:
=MOYENNE(DECALER($A$1;3*(LIGNE()-1);0;3;1)
 
Dernière édition:

Astyanax

XLDnaute Occasionnel
Bonjour Dranreb et merci pour la réponse.
C'est exactement ce que je désirais.
J'avais essayé avec un offset mais je me suis mal débrouillé.

Dans la formule, il manque une parenthèse en final.

Bonne journée et bon week-end à tous.
Astyanax
 

Discussions similaires

Réponses
10
Affichages
302

Statistiques des forums

Discussions
312 867
Messages
2 093 044
Membres
105 619
dernier inscrit
FRNCK