Microsoft 365 Erreur SOMMEPROD

Phoenix23

XLDnaute Occasionnel
Bonsoir à toutes et tous.
Dans le fichier ci-joint une erreur #VALEUR! suite a l'utilisation d'une formule SOMMEPROD.
Très probablement la formule n'est pas adaptée au résultat souhaiter.
Le détail, explication se trouvent dans la feuille "Tableau" du classeur ci-joint.
Si toutefois une personne pouvait SVP me venir en aide ?
D'avance Merci.
Très cordialement
 

Pièces jointes

  • 2023.05.13.xlsx
    14.6 KB · Affichages: 7

Gégé-45550

XLDnaute Accro
Bonsoir à toutes et tous.
Dans le fichier ci-joint une erreur #VALEUR! suite a l'utilisation d'une formule SOMMEPROD.
Très probablement la formule n'est pas adaptée au résultat souhaiter.
Le détail, explication se trouvent dans la feuille "Tableau" du classeur ci-joint.
Si toutefois une personne pouvait SVP me venir en aide ?
D'avance Merci.
Très cordialement
Bonsoir,
En C4 (puis C5 et C6), remplacer MOIS(C$2) par MOIS(DATEVAL("1 "&C$2))
VB:
=MIN(1;SOMMEPROD((MOIS('2023'!$A$2:$A$8)=MOIS(DATEVAL("1 "&C$2)))*(ESTNUM(TROUVE($A4;'2023'!$G$2:$G$8)))))
Cordialement,
 

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Une autre proposition avec une formule à valider sous forme matricielle :
Code:
=SOMME(ESTNUM('2023'!$A$2:$A$4)*(TEXTE('2023'!$A$2:$A$4;"mmmm")=C$2)*(SIERREUR(TROUVE($A3;'2023'!$G$2:$G$4);0)>0))


[edit] Ci-joint,une version avec Tableau Structuré [/edit]
 

Pièces jointes

  • 2023.05.13_(TooFatBoy-v1).xlsx
    21 KB · Affichages: 1
Dernière édition:

Discussions similaires

Réponses
9
Affichages
279

Statistiques des forums

Discussions
313 277
Messages
2 096 766
Membres
106 746
dernier inscrit
acquabateaux