XL 2021 Erreur dans formule index

Hugues1976

XLDnaute Nouveau
Bonjour à toutes et à tous.

J'ai un problème avec une fonction index. Elle ne retourne pas la valeur;

VB:
=SIERREUR(INDEX(Billing_Summary!$A$1:$B$20;EQUIV($AM6;Billing_Summary!$A$1:$A$7;0);2);"")

Donc, selon moi:
  1. La clef pour lier les 2 tables est dans la colonne A pour les 2 tables.
  2. La valeur sera copier dans la cellule AM6
  3. La valeur copier proviendra de la table Billing_Summary et sera dans la deuxième colonne de cette table.

Mais ca ne fonctionne pas.

MErci de votre support
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Hughes,
Avouez qu'un petit fichier test serait le bienvenu ?

De plus généralement les deux tables Equiv et Index ont la même taille.
Vous avez $A$1:$B$20 et $A$1:$A$7 donc vous ne pourrez adresser que la table de 1 à 7 au maximum. Donc dans tous les cas de figures exit la plage A8:A20.
 

Statistiques des forums

Discussions
313 320
Messages
2 097 135
Membres
106 848
dernier inscrit
toufk