XL 2016 Données API : cibler les données du moment

alain.raphael

XLDnaute Occasionnel
Bonjour à Tous,

En se basant sur un onglet avec liaison API (données Météo).....je souhaiterai aller chercher quelques éléments de la ligne correspodant au moment présent (h+2).

Ensuite prendre les autres lignes avec intervalle de 2 heures.

Exemple : il est en ce moment : 20 mai 20:03

Je vais chercher les éléments des lignes :

20 mai 22:00 Température, Pression, ....
21 mai 00:00 Température, Pression, ....
21 Mai 02:00 Température, Pression, ....
etc....

Fichier en exemple.... avec une formule intéressante mais non fonctionnelle

Merci..
 

Pièces jointes

  • Essai météo.xlsm
    166.6 KB · Affichages: 4

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Alain,
Un essai en PJ avec une formule de type :
VB:
=INDEX('API Site web'!$B$1:$B$1000;EQUIV(MAINTENANT()+$A4/24;'API Site web'!$B$1:$B$1000;1))
Avec en colonne A le delta time par rapport à l'heure présente.
( simplement pour simplifier les formules )
 

Pièces jointes

  • Essai météo.xlsm
    182.8 KB · Affichages: 3

alain.raphael

XLDnaute Occasionnel
Merci beaucoup Sylvanu..... l'horaire du moment changent les données ...

Est-ce que je peux automatiser une couleur sur les cellules contenant les mêmes journées (colonne des jours/horaires uniqument).

La mise en forme conditionnelle ne me le prends pas avec (GAUCHE(A1,1)=STXT(A1,2,1)) car il s'agit de cellules personnalisées...
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir,
Essayez de regrouper toutes les questions d'un coup, cela évite de reprendre N fois le travail.
Crois-tu que je puisse faire une colonne de cumul de pluie.....par jour...?
Oui, voir en PJ avec :
VB:
Pour la première ligne :
=SOMME.SI.ENS($E$3:$E$100;$B$3:$B$100;">="&ENT(B4);$B$3:$B$100;"<"&1+ENT(B4))
Pour le reste :
=SIERREUR(SI(JOUR(B5)=JOUR(B4);"";SOMME.SI.ENS($E$3:$E$100;$B$3:$B$100;">="&ENT(B5);$B$3:$B$100;"<"&1+ENT(B5)));"")
 

Pièces jointes

  • Essai météo (1) (1).xlsm
    184.4 KB · Affichages: 2

Discussions similaires

Statistiques des forums

Discussions
313 276
Messages
2 096 761
Membres
106 743
dernier inscrit
sshkm16