Stats - Base de données

pacoako

XLDnaute Occasionnel
Bonjour à tous les Excel Downloadiens! =)

j'ai un petit accrochage avec une stats. j'ai une base de données qui est comme ceci et qui est mise à jour par les Agents... une ligne = à une entrée ... et une entrée = un cas différent.

Code:
#Cas	Agent	Date  
09-8	AN8790	2009-02-02
09-9	AN8790	2009-02-02
09-10	AN8790	2009-02-02
09-11	AN8790	2009-02-04
09-12	AN8790	2009-02-05
09-13	AN8790	2009-02-04
09-14	AN8790	2009-02-02
09-15	AN8790	2009-02-02
09-16	AN8790	2009-02-02
09-17	AN8790	2009-02-02
09-18	AN8790	2009-02-02
09-19	AN8790	2009-02-09
09-20	AN8790	2009-02-09
09-21	CN0753	2009-01-06
09-22	AN8790	2009-02-16
09-23	AN8790	2009-02-19
09-24	AN8790	2009-02-19

Mon but est de compter les "Présences" pour un agent (Cellule A6) entre 2 date qui sont dans les cellules A2 et A4. À noter qu'il se peut qu'un agent entre plusieurs cas dans une journée dans la base de données...

Donc si on se donne l'exemple :

A2 = 2009-02-02
A4 = 2009-03-01
A6 = AN8790

AN8790 aurait 5 présences car on ne doit pas compter 2 fois une entrée pour la même date.

Croyez-vous qu'il est possible de faire un formule qui permet de trouver 5 comme réponse à cet exemple?... la seule façon que j'ai trouvé c'est avec un tableau croisé dyn. jumelé avec un autre tableau.. je trouvais ma solution vrmt trop complexe pour rien...

Auriez-vous une idée..?? Merci d'avance!! A +
 
G

Guest

Guest
Re : Stats - Base de données

Bonsoir Pacoako:
Les données étant en A9:C25

Code:
=SOMMEPROD(($C$9:$C$25>=A2)*($C$9:$C$25<=A4)*($B$9:$B$25=A6)*(1/NB.SI($C$9:$C$25;$C$9:$C$25)))

Retourne 5 2009-02-02 et 2009-03-01 étant exclus

Pas suffisament de cas différents pour voir si la formule est bonne tout le temps.

A+
 

pacoako

XLDnaute Occasionnel
Re : Stats - Base de données

Bonsoir Pacoako:

Pas suffisament de cas différents pour voir si la formule est bonne tout le temps.

A+


Resalut Hasco, si jamais tu reviens par ici, serais-tu en messure de m'expliquer la logique derrière ton 1/nb.si(laBDD;laBDD).. je ne suis pas certain de comprendre ce bout.. car si on l'isole.. j'obtient #Div/0!.

cette partie est-t-elle calculée différemment lorsqu'elle est inclue dans la formule sommeprod??? mercii encore


Voici ta formule adapté réelement à ma BDD qui est dans un autre fichier appelé Agents - RaQ.xls... est-ce bien ça? car j'obtient DiV/0! ici aussi
Code:
=SOMMEPROD(('[Agents - RaQ.xls]BDD'!$C$2:$C$65536>=DU)*('[Agents - RaQ.xls]BDD'!$C$2:$C$65536<=AU)*('[Agents - RaQ.xls]BDD'!$B$2:$B$65536=Agent)*(1/NB.SI('[Agents - RaQ.xls]BDD'!$C$2:$C$65536;'[Agents - RaQ.xls]BDD'!$C$2:$C$65536)))

Si j'essaie ton 1/nb.si seul comme ceci :
Code:
=1/NB.SI('[Agents - RaQ.xls]BDD'!$C$2:$C$65536;'[Agents - RaQ.xls]BDD'!$C$2:$C$65536)
J'obtient 0,9090909... est-ce normal?
 
Dernière édition:
G

Guest

Guest
Re : Stats - Base de données

Re,

1/nb.si(laBDD;laBDD)

Est la base d' une formule matricielle qui permet de trouver le nombre de valeur unique d'une zone et s'écrit individuellement comme suit

=Somme(1/nb.si(laBDD:laBDD))
Avec une validation par CTRL+MAJ+ENTRER.

Elle compare une à une les valeurs de LaBDD et renvoie VRAI (1) si elles sont identique.
Elle divise un par le nombre de valeurs équivalentes puis en fait la somme.

Comme sommeProd est en elle même une formule matricielle, la somme se fait automatiquement.

A+
 

Discussions similaires

Statistiques des forums

Discussions
313 260
Messages
2 096 634
Membres
106 692
dernier inscrit
oussama.badr