différencier rien de 0

B

bastoun

Guest
Bonjour à vous,

encore merci pour vos réponses si rapides hier,

Il ne me reste plus qu'un tout petit détail:
Est il possible dans une fonction SI de différencier une valeur 0 d'une cellule sans valeur?

en fait en A1 j'ai un chiffre, en A2 je peux avoir soit un chiffre soit rien
et en A3 ma fonction si qui fait la moyenne des deux sauf si il n'ya rien dans A2 ( dans ce cas la valeur serait 0 quelque soit le chiffre de A1) ... est ce bien clair ce que j'écris ??? :huh:
merci si vous comprenez quelques choses!
 

Oliver

XLDnaute Nouveau
Bonjour, Bastoun


la structure si est la suivante:

=SI(condition;alors;sinon)



dans ton cas
=SI(A2='';'';moyenne(A1;A2))


ou encore de maniere plus elegante, pour eviter les erreures


=SI(ESTNUM(A2);moyenne(A1;A2);'')

Message édité par: oliver, à: 15/09/2005 10:03
 
B

bastoun

Guest
merci pour tes précisions, mais ca ne marche pas et je crois savoir pourquoi...
J'ai oublié de préciser qu'au départ les chiffres de A1 et A2 sont des copies d'autres cellules... peut etre que ca influe sur la fonction?
merci de m'aider.
 
B

ba

Guest
je vous fais parvenir un exemple de mon soucis.

merci à vous [file name=score.zip size=2641]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/score.zip[/file]
 

Pièces jointes

  • score.zip
    2.6 KB · Affichages: 18
  • score.zip
    2.6 KB · Affichages: 19
  • score.zip
    2.6 KB · Affichages: 17
J

jocelyn

Guest
Bonjour le Forum,
Bonjour bastoun, Oliver, ljoue,


Je te renvoie ton fichier avec je crois les formules qui fonctionne

Espérant t'avoir aidé

Jocelyn [file name=score_20050915122356.zip size=2883]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/score_20050915122356.zip[/file]
 

Pièces jointes

  • score_20050915122356.zip
    2.8 KB · Affichages: 16

Discussions similaires

Réponses
22
Affichages
950

Statistiques des forums

Discussions
312 913
Messages
2 093 534
Membres
105 752
dernier inscrit
fred13340