copie cellule

judoka0209

XLDnaute Occasionnel
bonjour j'ai un petit soucis
j'ai dans la cellule A1 la lettre A,B,C,D,E ou F
et je veux que si A1='A' copier la cellule B1 en C1
ou si A1='B' copier la cellule B2 en C1
ou si A1='C' copier la cellule B3 en C1
etc.... jusqu'a la lettre F
merci
 

andré

XLDnaute Barbatruc
Salut,

Il existe, par formule, au moins quatre possibilités :

En C1 : =SI(A1='A';B1;SI(A1='B';B2;SI(A1='C';B3;SI(A1='D';B4;SI(A1='E';B5;SI(A1='F';B6;''))))))
Cette méthode est toutefois limitée à 7 SI imbriqués.

Uniquement valable pour des valeurs sont numériques en colonne B:B :
(A1='A')*B1+(A1='B')*B2+(A1='C')*B3+(A1='D')*B4+(A1='E')*B5+(A1='F')*B6
Il n'y a pas de limite.

Pour aller au-delà des 7 SI imbriques, il faut passer par un tableau de correspondance :
Première colonne :A, B, C, ...
Deuxième colonne : B1, B2, B3, ...
En C1 la formule : =INDIRECT(RECHERCHEV(A1;tableau;2;0))

Si le texte en A1 est bien une lettre de l'alphabet en commençant par la lettre A :
En C1 : =INDIRECT('B'&CODE(A1)-64)

Voilà un début pour les formules,mais il existe encore les macros !

Â+
 

Discussions similaires

Statistiques des forums

Discussions
300 718
Messages
1 986 644
Membres
209 555
dernier inscrit
Cookone