Construction fonction avec nombreuses conditions

zendb

XLDnaute Junior
Bonjour,

Je cherche à construire une fonction avec plusieurs conditions,
Je veux qu'une cellule prenne une valeur si le contenu de deux autres cellules appartiennent à 2 listes différentes, si la condition n'est pas respectée alors la cellule prend une autre valeur.


Ci joint le fichier excel

Merci !!! :)
 

Pièces jointes

  • Classeur1.xlsx
    9.5 KB · Affichages: 52

CISCO

XLDnaute Barbatruc
Bonjour à tous, bonjour JHA

Quelques variantes
Code:
=SI(A2="";"";SI(ESTNUM(EQUIV(A2;Liste_1;0))*ESTNUM(EQUIV(B2;DECALER(G1:I1;EQUIV(A2;Liste_1;0););0));"Oui";"Non"))

Code:
=SI(A2="";"";SI(ESTNUM(EQUIV(A2;Liste_1;0))*ESTNUM(EQUIV(B2;INDIRECT(A2);0));"Oui";"Non"))

et même peut être
Code:
=SIERREUR(SI(A2="";"";SI(EQUIV(A2;Liste_1;0)*EQUIV(B2;INDIRECT(A2);0);"Oui";"Non"));"Non")

@ plus
 

Discussions similaires

Réponses
4
Affichages
293

Statistiques des forums

Discussions
312 938
Messages
2 093 779
Membres
105 823
dernier inscrit
sawosko