XL 2021 Compter les cellules qui contiennent...

fifounet

XLDnaute Occasionnel
Bonjour, j'aimerais savoir comment compter dans une zone de cellule "$A$3:I$33" le nombre de mots contenant une lettre "BA3" hormis la première lettre.
J'essaie de partir de la formule qui compte le nombre de mots commençant par une lettre => NB.SI($A$3:I$33;BA3&"*").
Je n'y arrive pas en une seule formule!
Merci de votre aide
Philippe
 
Solution
bonjour à toutes est à tous, bonjour @fifounet

Recherche des mots contenant une lettre hormis l'initiale
avec une de ces 2 formules selon que tu veuilles distinguer la casse ou non​
Sensible à la casse : =SOMME(ESTNUM(TROUVE($AB$3;$A$3:$I$33;2))*1)​
Insensible à la casse : =SOMME(ESTNUM(CHERCHE($AB$3;$A$3:$I$33;2))*1)​
Recherche des mots commençant pas une lettre
casse indépendant =SOMME(SIERREUR(CHERCHE($AB$3;$A$3:$I$33;1)=1;0)*1)​
casse dépendant =SOMME(SIERREUR(TROUVE($AB$3;$A$3:$I$33;1)=1;0)*1)​
EDIT pour ce 2ième cas ta formule plus simple convient parfaitement (=NB.SI($A$3:I$33;$BA$3&"*").


Avec excel 2021 pas la peine de valider comme une formule matricielle (CTRL MAJ...

AtTheOne

XLDnaute Accro
Supporter XLD
bonjour à toutes est à tous, bonjour @fifounet

Recherche des mots contenant une lettre hormis l'initiale
avec une de ces 2 formules selon que tu veuilles distinguer la casse ou non​
Sensible à la casse : =SOMME(ESTNUM(TROUVE($AB$3;$A$3:$I$33;2))*1)​
Insensible à la casse : =SOMME(ESTNUM(CHERCHE($AB$3;$A$3:$I$33;2))*1)​
Recherche des mots commençant pas une lettre
casse indépendant =SOMME(SIERREUR(CHERCHE($AB$3;$A$3:$I$33;1)=1;0)*1)​
casse dépendant =SOMME(SIERREUR(TROUVE($AB$3;$A$3:$I$33;1)=1;0)*1)​
EDIT pour ce 2ième cas ta formule plus simple convient parfaitement (=NB.SI($A$3:I$33;$BA$3&"*").


Avec excel 2021 pas la peine de valider comme une formule matricielle (CTRL MAJ ENTREE)

Voir pièce jointe
 

Pièces jointes

  • Cherche letrre dans liste de mots.xlsx
    11.6 KB · Affichages: 3
Dernière édition:

AtTheOne

XLDnaute Accro
Supporter XLD
Bonjour @JHA
Moi j'ai compris une lettre dans la cellule BA3, toi la chaîne "BA3" , attendons la réaction de @fifounet

J'ai ajouté 2 formats conditionnels pour mettre en évidence les cellules qui matchent (sensible ou non à la casse)
voir pièce jointe

A bientôt
 

Pièces jointes

  • Cherche letrre dans liste de mots.xlsx
    12.1 KB · Affichages: 4

Discussions similaires

  • Question
XL pour MAC mise en forme
Réponses
2
Affichages
359

Statistiques des forums

Discussions
313 309
Messages
2 097 031
Membres
106 812
dernier inscrit
Excellou74