compter le nombre de fois qu'apparait des noms dans un tableau

neos666

XLDnaute Nouveau
Bonjour, voila ma question es la suivante j'ai un tableau excel avec des noms de personnes dedans. Je voudrais savoir si il existe une fonction qui me permettrai de savoir combien de fois ce trouve le nom de chaque personne dans ce tableau?

Merci d'avances
 

neos666

XLDnaute Nouveau
Re : compter le nombre de fois qu'apparait des noms dans un tableau

Salut, ben en fait c'est la foncion que j'utilise pour le moment, mais je dois la recopier pour chaque nom. Il existerait pas une fonction qui m'eviterait de devoir retaper la fonction pour chaque nom?
Merci
 

patrickV

XLDnaute Nouveau
Re : compter le nombre de fois qu'apparait des noms dans un tableau

"Jean" peut être une référence.

Par exemple, tu fais une liste des noms dans la colonne D :

D1 : Jean
D2 : Albert
D3 ...

puis tu mets la formule :

=NB.SI($A$1:$C$12;D1)

Et tu la tire vers le bas :
=NB.SI($A$1:$C$12;D2)
=NB.SI($A$1:$C$12;D3)
=...

Attention aux "$" à ajouter si tu recopie la formule

Patrick
 

alcalzone

XLDnaute Occasionnel
Re : compter le nombre de fois qu'apparait des noms dans un tableau

Bonsoir à tous,

Je rebondis sur la question de neos666.
Sur l'exemple de Dull, =NB.SI(A1:C12;"Jean")
Peut-on compter le nombre de cellule= Jean avec une condition.
Exemple: en C12, j'ai Jean. Résultat =1
Je voudrais ajouter la condition si D12 est > à 0 alors compter 1, si D12=1 alors ne pas compter ce Jean.
Je n'ai pas trouver la bonne syntaxe avec Nb.si

Merci de votre aide
 

alcalzone

XLDnaute Occasionnel
Re : compter le nombre de fois qu'apparait des noms dans un tableau

Rectification

Bonsoir à tous,

Je rebondis sur la question de neos666.
Sur l'exemple de Dull, =NB.SI(A1:C12;"Jean")
Peut-on compter le nombre de cellule= Jean avec une condition.
Exemple: en C12, j'ai Jean. Résultat =1
Je voudrais ajouter la condition si D12 est > à 10 alors compter 1, si D12=1 alors ne pas compter ce Jean.
Je n'ai pas trouver la bonne syntaxe avec Nb.si

Merci de votre aide
 

Discussions similaires

Réponses
13
Affichages
453

Statistiques des forums

Discussions
312 842
Messages
2 092 714
Membres
105 517
dernier inscrit
Freddy93