XL 2019 Compter cellules colorées par MFC

lolo42

XLDnaute Occasionnel
Bonjour à tous,

malgré mes recherches de code VBA et codes , je n'arrive pas à compter le nombre de cellule coloré en bleu (RTT) par MFC.
Merci encore pour vos connaissances précieuses.

Cordialement
 

Pièces jointes

  • Copie de fonction-compte-couleur-sur-mfc.xlsm
    16.3 KB · Affichages: 7

djidji59430

XLDnaute Barbatruc
Bonjour à tous,

On ne peut pas compter les cellules colorées en MFC.
Il suffit de compter le nb d'occurence de la condition a 1 (ce qui est plus logique, on traite la cause, pas l'effet). Ici tu comptes directement les cellules qui contiennent "RTT"

Crdlmt
 
Dernière édition:

sylvanu

XLDnaute Barbatruc
Supporter XLD

Pièces jointes

  • Copie de fonction-compte-couleur-sur-mfc.xlsm
    18.4 KB · Affichages: 19

lolo42

XLDnaute Occasionnel
Bonjour Lolo,

Compter les couleurs par MFC est beaucoup moins simple que de compter les couleurs de fond de cellule.

Un essai en PJ directement issu de https://www.excel-downloads.com/threads/compter-couleurs-mfc-mise-en-forme-conditionnelle.20020548/
La syntaxe est : =NbMFCColor($A$1:$A$15;N) avec N index couleur

Ceci dit dans votre exemple, il serait beaucoup plus simple de faire :
VB:
=NB.SI(A:A;"RTT")
:)
MERCI BEAUCOUP.
C est exactement ce que je cherchais. Bravo pour vôtre aide.
Bon week end à tous
 

Discussions similaires

Réponses
2
Affichages
94
Réponses
4
Affichages
287

Statistiques des forums

Discussions
312 841
Messages
2 092 708
Membres
105 514
dernier inscrit
Hébera