Microsoft 365 Comment récupérer la valeur qui ?

thireg

XLDnaute Junior
bonjour,

Une aide svp ...

j'aimerais récupérer, dans le champ D6 , la valeur de la colonne AB , qui correspond à la 1ére valeur en descendant de la colonne AC (1500 lignes) qui comprend le mot "LIBRE".

ICI dans l'image, je dois donc récupérer en D6 , la valeur 22-EX-0011B678 ...

Je ne sais pas comment faire ? (sinon il suffit de faire une rechercheV inversée) ... Mais sinon ?

Merci pour votre aide ...

2022-04-04_105211.jpg
 
Dernière édition:

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Thireg,
Edit : Bonjour Djidji,
Un petit fichier test eût été préférable à une image, difficilement exploitable sous XL.
Un essai en PJ avec :
Code:
=SI(LIGNES($2:2)<=NB.SI($AC$2:$AC$40;"LIBRE");INDEX($AB$2:$AB$40;PETITE.VALEUR(SI($AC$2:$AC$40="LIBRE";LIGNE(INDIRECT("1:"&LIGNES($AC$2:$AC$40))));LIGNES($2:2)));"")
Formule à valider avec Maj+Ctrl+Entrée car matricielle.
 

Pièces jointes

  • Thireg.xlsx
    10.4 KB · Affichages: 2
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
299 878
Messages
1 979 752
Membres
206 858
dernier inscrit
M.nahali