Comment éviter la formule #DIV/0! dans une cellule

abuelo

XLDnaute Nouveau
Bonjour à tous,
Je me permets de solliciter votre aide en tous sens ! !
De par mon pseudo (Grand Père en Espagnol) vous comprendrez que je ne suis plus tout jeune ! ! !alors veuillez m'excuser si ma question vous parait quelque peu "simple"

Je désirerais (pour la beauté de la feuille) éviter qu'aparaisse dans mon tableau la formule #DIV/0!
La cellule concernée contient la formule suivante: =A$1*1*(SOMME.SI(C3;">0,5"))/C$3:C$10
formule qui malgré qu'elle fonctionne je suspecte d'être racourcie !
A1 contenant une valeure qui doit rester fixe
En colone F j'ai décoché l'option "afficher un zero dans les cellules qui ont une valeur nulle"
En colonnes G et H j'utilise la formule "SI(ESTERREUR
Héls en colonne E je ne trouve pas la solution.
je joint le fichier pour votre compréhension.
D'avance merci à ceux (celles) qui pouraient me dépanner.
Abuelo
 

Pièces jointes

  • modèle.xlsx
    11.5 KB · Affichages: 59
  • modèle.xlsx
    11.5 KB · Affichages: 64
  • modèle.xlsx
    11.5 KB · Affichages: 66

R@chid

XLDnaute Barbatruc
Re : Comment éviter la formule #DIV/0! dans une cellule

Bonsoir et Bienvenu sur XLD,

tu veux peut être diviser par la somme de C$3:C$10,
Code:
=A$1*SOMME.SI(C3;">0,5")/SOMME(C$3:C$10)

si c'est pas ça essayer,
=SIERREUR(TaFormule;0)


Amicalement
 

abuelo

XLDnaute Nouveau
Re : Comment éviter la formule #DIV/0! dans une cellule

Merci beaucoup R@chid.
J'avais essayé bien des formules en vain, grâce à ton aide je suis enfin soulagé.
Cela me prouve encore une fois que la bonne volonté des hommes est bien la plus belle des choses dans ce bas monde.
Bien à toi
Abuelo
 

Dranreb

XLDnaute Barbatruc
Re : Comment éviter la formule #DIV/0! dans une cellule

Bonsoir abuelo, R@chid.
La formule originelle, telle qu'elle était écrite, revenait à :
Code:
=SI($C3>0,5;$A$1;0)
Celle corrigée par R@chid:
Code:
=A$1*SOMME.SI(C3;">0,5")/SOMME(C$3:C$10)
revient à:
Code:
=$A$1*SI($C3>0,5;$C3;0)/SOMME($C$3:$C$10)
Enfin bref, pourquoi faire un SOMME.SI pour un seul élément ?
En tout cas ça ne calcule pas, comme je soupçonne qu'on voulait le faire, des parts du total frais fixes au prorata des "nombre" supérieurs à 0,5
Celle qui ferait ça ce serait plutôt celle là:
Code:
=SI($C3>0,5;$A$1*$C3/SOMME.SI($C$3:$C$10;">0,5");0)
À vous deux de jouer maintenant.
À +
 
Dernière édition:

R@chid

XLDnaute Barbatruc
Re : Comment éviter la formule #DIV/0! dans une cellule

Re,
Oui bien-sur, mais je ne sais pas vraiment si il veut éliminer les C<0,5 ou non, déjà il n’était pas clair dans ses explications malgré un long texte...
@ + + sur les fils d’araignée
@ micalement
 

Discussions similaires

Statistiques des forums

Discussions
312 841
Messages
2 092 709
Membres
105 517
dernier inscrit
Freddy93