Classer/Trier des valeurs

gimx

XLDnaute Junior
Bonjour,

J'ai un souci pour trier des valeurs.
En colonne A B C, j'ai des données.
Mon but est de trier ces données pour faire une recherche dessus.



Dans l'exemple, je voudrais que de E à H, les données soient rangées par ordre alphabétique, puis par ordre croissant. Le but c'est que je puisse mettre une formule aprés pour numéroter de 1 à x les valeurs de chaque nom. Ensuite, sur une autre feuille, si j'ai Dupond avec une valeur de 57, via une fonction de recherche, j'obtiens le rang, ici 2.
Je suis clair ? :)

Si quelqu'un a une idée...
Ou si quelqu'un voit plus simple pour le faire aussi ;)

Etant donné que je ne suis pas un pro de fonctions matricielles ou vba, j'aimerais éviter autant que possible de les utiliser pour le moment. Si il n'y a pas d'autres moyens que vba, je veux bien si on me commente le code pour que je puisse le refaire comme un grand.

Merci à vous :)
 

Pièces jointes

  • exemple.xls
    13.5 KB · Affichages: 94
  • exemple.xls
    13.5 KB · Affichages: 95
  • exemple.xls
    13.5 KB · Affichages: 82

dixit

XLDnaute Impliqué
Re : Classer/Trier des valeurs

bonjour,
peut-être un début de solution avec la fonction sommeprod
voici un fichier extrait de mon site perso où il y a des informations complémentaires.
bye
 

Pièces jointes

  • sommeprod.xls
    19 KB · Affichages: 103
  • sommeprod.xls
    19 KB · Affichages: 105
  • sommeprod.xls
    19 KB · Affichages: 97

gimx

XLDnaute Junior
Re : Classer/Trier des valeurs

Super ! Merci à toi.
J'essaye ce soir et je te dis mais ça m'a l'air de répondre parfaitement à ce que je voudrais. Le tout c'est de le refaire correctement... :p
Bien ton site, je le mets en favoris :)
 

Monique

Nous a quitté
Repose en paix
Re : Classer/Trier des valeurs

Bonjour,

Rang alpha donné par Nb.Si
=NB.SI(B$2:B$13;"<="&B2)

"Rang" alpha + note/10000 pour départager le "rang"
=NB.SI(B$2:B$13;"<="&B2)+C2/10000

Index Equiv pour trouver le nom correspondant puis la note puis la date
SommeProd pour les n° 1, 2, 3
 

Pièces jointes

  • RangAlphaGimx.zip
    3.4 KB · Affichages: 79

Monique

Nous a quitté
Repose en paix
Re : Classer/Trier des valeurs

Bonjour,

Comment ça se fait ?
Je ne sais pas mais c'est utile.
A est inférieur à B
Zzzzz est supérieur à Zz

SommeProd le fait aussi, (si on a d'autres critères à ajouter)
Rien que du texte en colonnes A (des noms) et B (absent ou présent) :
=SOMMEPROD((A2:A6<"Durand")*(B2:B6="Absent"))
 

Membres actuellement en ligne

Statistiques des forums

Discussions
312 084
Messages
2 085 194
Membres
102 812
dernier inscrit
abdouami