Calculer le n° du mois en fonction du n°semaine

Bilou

XLDnaute Nouveau
Bonjour à tous,

J'ai réellement besoin de vos lumières. Pourriez-vous m'expliquer comment calculer le numéro du mois en fonction du numéro semaine, et non de la date du jour.

Ex : le 01/03/08
=> mois "du jour" : mars
=> semaine "du jour" : 09

Or, voilà ce que je souhaite obtenir
=> mois "de la semaine" : février

Merci d'avance pour votre aide
 

thomlau

XLDnaute Occasionnel
Re : Calculer le n° du mois en fonction du n°semaine

Bonjour Bilou, bonjour le forum.

Il me semble inutile de chercher le n° du mois à partir de la semaine, en faisant simplement =mois(A1) et en supposant que la date du jour soit en A1 tu parviens rapidement à tes fins.

D'un autre côté, je ne sais pas si c'est possible de trouver le mois à partir de la semaine...

Bonne journée à tous.
 

Staple1600

XLDnaute Barbatruc
Re : Calculer le n° du mois en fonction du n°semaine

Bonjour à tous


Regardes dans ce fichier
(réalisé par Monique)

En s'inspirant d'une formule qui s'y trouve
Numéro de semaine en A1 (donc avec ton exemple: 9 )
en B1, saisir cette formule
=TEXTE(DATE(ANNEE(AUJOURDHUI());1;1)+(A1-1)*7-MOD(DATE(ANNEE(AUJOURDHUI());1;1)-2;7);"mmmm")
renvoie en B1 : février.
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 113
Messages
2 085 427
Membres
102 889
dernier inscrit
monsef JABBOUR