Microsoft 365 Calcul de temps de prise en charge hors fermeture

Sandra 42

XLDnaute Nouveau
Bonjour,

J'aimerai pouvoir calculer le temps de prise en charge d'une demande hors temps de fermeture.
Les horaires d'ouverture sont de 9h à 18h.
Cela fonctionne avec la formule ci-jointe mais pas si le mail arrive durant le temps de fermeture.

=SI(NB.JOURS.OUVRES($B8;$C8)=1;MIN($C8-ENT($C8);$G$2/24)-MAX($B8-ENT($B8);$F$2/24);MIN($C8-ENT($C8);$G$2/24)-$F$2/24+$G$2/24-MAX($B8-ENT($B8);$F$2/24)+SI(NB.JOURS.OUVRES($B8;$C8)>2;(NB.JOURS.OUVRES($B8;$C8)-2)*($G$2-$F$2)/24;0))

Je vous remercie de votre aide.

1710513490891.png
 

Lu76Fer

XLDnaute Occasionnel
Bonjour Sandra,
J'ai repris la deuxième partie de la formule et l'ai décomposée dans 4 cellules :
E9=MIN($C9-ENT($C9);$G$2/24)
F9=$F$2/24+$G$2/24-MAX($B9-ENT($B9);$F$2/24)
G9=SI(NB.JOURS.OUVRES($B9;$C9)>2;(NB.JOURS.OUVRES($B9;$C9)-2)*($G$2-$F$2)/24;0)
Et Enfin
H9=E9-F9+G9
Et on obtient : 5:10:00
Je ne sais pas si c'est un bon résultat ... Il est étrange que tout fonctionne qu'en la formule est décomposée et qu'elle génère une erreur une fois rassemblée ?? J'ai testé en remplaçant E9, F9 et G9 par leur formule respective et erreur ... Le changement du format de cellule n'affecte pas non plus le résultat.​

En espérant vous faire avancer dans votre réflexion !
 

Pilou37

XLDnaute Nouveau
Bonjour,
Je vous propose ceci : créer dans une nouvelle feuille "Paramètres" une table de jours fériés que vous nommez "Fériés", une cellule avec l'heure de début (9:00) de chaque jour que vous nommez "Début", idem pour l'heure de fin (18:00) nommée "Fin".
Ensuite, dans une nouvelle colonne "Date demande corrigée" on installe une formule pour corriger la date de début de prise en compte de la demande :
Si date demande est un jour ouvré OU heure demande > heure fin
Alors demande = jour ouvré suivant à heure début
Sinon Si heure demande < heure début
Alors heure demande = heure début
Sinon date demande initiale

Puis dans la colonne du calcul du nb d'heures de traitement :
Si date réponse = date demande
Alors heure réponse - heure demande
Sinon Si nb jours ouvrés entre dates = 2
Alors heure fin - heure demande + heure réponse - heure début
Sinon (nb jours ouvrés-2) * heure début + heure fin - heure
demande + heure réponse - heure début

Ca marche impeccable avec tous les cas de figure. Voir en fichier joint les formules et le résultat.
A votre service,
Pilou37
 

Pièces jointes

  • Calcul nb heures traitement demandes.xlsx
    26.5 KB · Affichages: 4

Discussions similaires

Statistiques des forums

Discussions
313 204
Messages
2 096 206
Membres
106 528
dernier inscrit
Sabrnajean