Calcul automatique de la date et éviter les date de week-end

roncevaux68

XLDnaute Junior
Bonjour à tous,

Je voudrai faire un calcul de la date du jour d’après en évitant les week-end
Tous cela en automatique

Ci joint un exemple

cordialement
ps :je travail avec excel 2000
 

Pièces jointes

  • Classeur1.xls
    17.5 KB · Affichages: 77
  • Classeur1.xls
    17.5 KB · Affichages: 74
  • Classeur1.xls
    17.5 KB · Affichages: 79

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Calcul automatique de la date et éviter les date de week-end

Bonjour roncevaux68,

Si la date est en D26, essayer cette formule en C26:
Code:
=D26+CHOISIR(JOURSEM(D26);1;1;1;1;1;3;2)

Appliquer un format à une cellule ne modifie en rien sa valeur "interne". Si vous appliquez le format "jjjj" à une cellule date, elle affichera le nom du jour mais elle contiendra réellement toujours une valeur date.

La valeur interne d'une date est un entier qui est un numéro de série (1 étant le 01 janvier 1900, 2 étant le 02 janvier 1900, etc.)

Lorsque vous comparez, dans vos formules, une date avec la chaine de caractères "vendredi", vous comparez en fait la chaine de caractères "vendredi" à un numéro de série qui est un nombre entier. Le résultat de la comparaison retourne donc toujours faux.

Pour le mettre en évidence, saisir une date dans une cellule et appliquer le format "Standard" à la cellule
-> vous verrez le numéro de série de la date saisie.
 

JBARBE

XLDnaute Barbatruc
Re : Calcul automatique de la date et éviter les date de week-end

Bonjour,

Comme ceci j'espére que cela te conviens !

A+
 

Pièces jointes

  • Classeur1-1.xls
    53.5 KB · Affichages: 88
  • Classeur1-1.xls
    53.5 KB · Affichages: 87
  • Classeur1-1.xls
    53.5 KB · Affichages: 86

Papou-net

XLDnaute Barbatruc
Re : Calcul automatique de la date et éviter les date de week-end

Bonjour roncevaux68,

Il est plus simple d'utiliser la fonction native JOURSEM, par exemple :

Code:
=SI(JOURSEM(D26;2)>=5;D26+8-JOURSEM(D26;2);D26+1)
Dans cette formule, si JOURSEM >= 5 (vendredi), on ajoute 8 - n° du jour à D26 pour obtenir la date du lundi suivant. De ce fait, la cellule intermédiaire E26 n'est plus utile.

Tu peux obtenir des détails sur cette instruction en la sélectionnant puis en appuyant sur F1.

Cordialement.
 

Pièces jointes

  • Copie de Classeur roncevaux68.xls
    17.5 KB · Affichages: 63
Dernière édition:

Staple1600

XLDnaute Barbatruc
Re : Calcul automatique de la date et éviter les date de week-end

Bonjour à tous


Un autre voie sans formule: la recopie vers le bas en choisissant : Incrémenter les jours ouvrés
1)
​ Sélection de la cellule contenant la date de début
2) Recopie vers le bas en cliquant droit, ce qui fait apparaître le menu contextuel
Choisir alors l'option voulue
(voir copie d'écran ci-dessous)
jouro.jpg

EDITION: Une autre autre solution : utiliser Serie (dans l'onglet ACCUEIL/Edition)
serie.jpg
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 913
Messages
2 093 534
Membres
105 751
dernier inscrit
fred13340