bug somme heure et #valeur! pourquoi

La Vouivre

XLDnaute Occasionnel
je fais un fichier pour compter les heures de travail et j'ai cherche sur le forum la solution à mon problème sans trouver la solution,c'est pourquoi je viens solliciter votre aide .
Je fais la somme d'une colonne et #valeur! apparaît
Que se passe t'-il ?
Pouvez-vous m'indiquer l'erreur que je fais ?
Merci de votre précieuse aide
 

Pièces jointes

  • calendrierv.zip
    15 KB · Affichages: 28
  • calendrierv.zip
    15 KB · Affichages: 31
  • calendrierv.zip
    15 KB · Affichages: 26

TooFatBoy

XLDnaute Barbatruc
Re : bug somme heure et #valeur! pourquoi

Désolé, mon accés au Net est hyper lent, mais je viens enfin d'arriver à télécharger ton fichier...

Tu as un code d'erreur en E35 et E36, donc la somme de E6 à E36 ne peut renvoyer autre chose qu'un code d'erreur.
Il faudrait mettre un zéro en E35 et E36.


PS : pour ta formule en colonne E tu devrais pouvoir la simplifier en te référant à la colonne C qui est cachée.
 
Dernière édition:
C

Compte Supprimé 979

Guest
Re : bug somme heure et #valeur! pourquoi

Salut LaVouivre,

Normal que tu es un #Valeur! puisque tu as un #Valeur dans les cellules E35 et E36 don le résultat ne peut être qu'une erreur !

A+
 

La Vouivre

XLDnaute Occasionnel
Re : bug somme heure et #valeur! pourquoi

Merci à vous Marcel et Jean Pierre, pour la colonne heure normale ça marche, mais apparemment il me faut aussi changer la formule en colonne jour, car pour les mois de moins de 31 jours j’ai l’erreur qui apparaît, et là je ne sais pas comment faire
 

kjin

XLDnaute Barbatruc
Re : bug somme heure et #valeur! pourquoi

Bonsoir,
J'ai rajouter la fonction Temps dans ta formule
=SI(OU(D6="L";D6="M";D6="ME";D6="J";D6="V");TEMPS(7;36; );SI(OU(D6="S";D6="D");" ";" "))
et modifié les formules fin de mois
A voir
A+
kjin
 

Pièces jointes

  • calendrierv.zip
    17.9 KB · Affichages: 30
  • calendrierv.zip
    17.9 KB · Affichages: 21
  • calendrierv.zip
    17.9 KB · Affichages: 26
Dernière édition:
C

Compte Supprimé 979

Guest
Re : bug somme heure et #valeur! pourquoi

Re,

Tu trouveras ci-joint ton fichier modifié
J'ai modifié les formules également pour afficher le jour L,M,M,J,V,S ou D

Dans la formule d'affichage des heures, je met 0 si c'est un S ou D

Avec une MFC, je mets les O en blanc comme ça ils ne se voient pas ;)
et le calcul est bon ....

A+
 

Pièces jointes

  • LaVouivre_CalendrierV.zip
    14.2 KB · Affichages: 13
Dernière modification par un modérateur:

kjin

XLDnaute Barbatruc
Re : bug somme heure et #valeur! pourquoi

Re,
Pourquoi pas ne rien faire apparaître du tout pour ces cellules ?
Il suffit de faire une recopie incrémentée de (A35: D35) sur (A34: D34), ce que j'avais oublié ! Mille excuses
A+
kjin
 

La Vouivre

XLDnaute Occasionnel
Re : bug somme heure et #valeur! pourquoi

Merci à tous
C’est pile poil ce que je recherchais, vous êtes vraiment très très fort , je dirais bien que vous êtes phénoménal et que vous avez une place dans le journal de Claire Chazal .
Bonne soirée à tous
Bon week end
 

Discussions similaires

Statistiques des forums

Discussions
312 884
Messages
2 093 242
Membres
105 658
dernier inscrit
Mario Richard