Budget....

Clochard

XLDnaute Impliqué
Bonjour à tous et toutes...

Voilà ... j'aimerais lorsque j'inscrive une dépense codée dans la colonne B quelle s'inscrive automatiquement dans la colonne appropriée...

Je cherche depuis des heures la bonne formule... mais je pioche :mad:

Merci d'avance

clochard
 

Pièces jointes

  • Budget départemental2.xls
    23.5 KB · Affichages: 115

cbea

XLDnaute Impliqué
Re : Budget....

Bonsoir Clochard,

Voici une solution.

Formule à mettre en E2 :
=SI($B2="";"";SI(INDEX($L$3:$L$7;EQUIV($B2;$K$3:$K$7;1);1)=E$1;$D2;""))

Ensuite, recopier vers la droite jusqu'à la colonne I et vers la ligne 20.
 

Clochard

XLDnaute Impliqué
Re : Budget....

Salut Cbea

Le seul problème c'est que si j'inscris tout autre nombre que de 1à 5... genre 6, 7, 8 ou 9... il me place le montant sur le 5...

J'aime bien cette formule... si l'on pouvait y remédier...

Merci à toi

Clauchard
 

cbea

XLDnaute Impliqué
Re : Budget....

Bonsoir Clochard,

Voici une autre formule à mettre en E2 :

=SI(OU($B2="";ESTERREUR(EQUIV($B2;$K$3:$K$7;0)));"";SI(INDEX($L$3:$L$7;EQUIV($B2;$K$3:$K$7;0);1)=E$1;$D2;""))

A recopier vers la droite et vers le bas.
 

Discussions similaires

Réponses
2
Affichages
309
Réponses
2
Affichages
120

Statistiques des forums

Discussions
312 001
Messages
2 084 481
Membres
102 581
dernier inscrit
Michou