XL 2010 Besoin d aide formule Excel 2010

Mustang007

XLDnaute Nouveau
Bonjour,

Et désolé de vous déranger, j'aurai besoin d'aide sous Excel, et j'espere que quelqu'un ici pourra m'aider.

J'aimerais classer des objets en fonction de différents parametres. En fonction des valeurs (ou nom) des parametres, j'aimerais attribuer un score pour chacun de ceux-ci. Le but final étant d'avoir le score total de chacun des objets afin de les classer, ou faire des diagrammes araignees.

Vous trouverez en piece jointe un exemple du tableur.

Par avance, je vous remercie pour votre aide, bien a vous.
Tableur.JPG


https://img-19.ccm2.net/S8Z8qO8KwvW...0b82448a5ac18ded3384313ef/ccm-ugc/Tableur.JPG
 
Solution
Alleluia!! Finalement, j'ai réussi! a base de Si (Et(B4>=X;B4<X....
Dans tous les cas, je vous remercie pour votre aide, et le temps que vous avez passé a me répondre! ça fait toujours plaisir l'entraide! Continuez ainsi!! bonne journée a tous!!

AtTheOne

XLDnaute Accro
Supporter XLD
Bonjour à toutes & à tous, bonjour @Mustang007, bonjour @TooFatBoy :
Tu trouveras en pièce jointe un exemple de proposition avec le tableur Excel :
Capture.png
🤣🤣 Mort de rire ...

En plus de fournir un fichier utilisable et non pas une image, il faudrait que tu précises les bornes de tes conditions numériques, parce que comme tu le présentes les bornes sont exclues.
Il faudrait aussi des <= ou des >=.
A bientôt
 

TooFatBoy

XLDnaute Barbatruc
Salut AtTheOne ;)
T'as remarqué aussi qu'on avait de plus en plus de pros de PhotoShop qui trainaient dans le coin ? 🤔

il faudrait que tu précises les bornes de tes conditions numériques, parce que comme tu le présentes les bornes sont exclues.
Il faudrait aussi des <= ou des >=.
Tout à fait d'accord avec toi, c'est pourquoi j'ai ajouté une deuxième proposition plus béton. ;)
(tant qu'à créer un fichier pour tester les formules en partant d'une capture d'écran, autrement dit de zéro, autant essayer de l'optimiser à sa sauce ;-) )



Au fait : bienvenue sur le forum Mustang007 ;)

C'est pas une 007 mais une 2024...
Elle est quand même sympa. Non ?
Mustag-GT-2024.jpg

Dommage qu'il y ait un malus "écologique" de... 60 000 € !!! 😭
 
Dernière édition:

TooFatBoy

XLDnaute Barbatruc
Le temps que j'allume mon PC et je t'envoie mon fichier puis regarde le tien.


[edit]
Mon fichier en pièce jointe.
Bon, la formule est un peu moisie, mais elle fonctionne. ;)
[/edit]
 

Pièces jointes

  • Mustang007-2.xlsx
    19.4 KB · Affichages: 2
Dernière édition:

TooFatBoy

XLDnaute Barbatruc
Tu m'étonnes que je n'arrive pas a écrire la formule...quand je vois la tienne, je perds mes cheveux...
Voui, désolé, je n'ai pas trouvé mieux. :(

Elle est peut-être plus lisible comme ça :
Code:
=SIERREUR(SI(C3="";0;INDEX($L$2:$P$2;1;EQUIV($C3;$L$3:$P$3;1)));0)
+SIERREUR(SI(D3="";0;INDEX($L$5:$P$5;1;EQUIV($D3;$L$6:$P$6;1)));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(E3;$L$7:$P$7;0));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(F3;$L$8:$P$8;0));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(G3;$L$9:$P$9;0));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(H3;$L$10:$P$10;0));0)
 

Mustang007

XLDnaute Nouveau
Voui, désolé, je n'ai pas trouvé mieux. :(

Elle est peut-être plus lisible comme ça :
Code:
=SIERREUR(SI(C3="";0;INDEX($L$2:$P$2;1;EQUIV($C3;$L$3:$P$3;1)));0)
+SIERREUR(SI(D3="";0;INDEX($L$5:$P$5;1;EQUIV($D3;$L$6:$P$6;1)));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(E3;$L$7:$P$7;0));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(F3;$L$8:$P$8;0));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(G3;$L$9:$P$9;0));0)
+SIERREUR(INDEX($L$5:$P$5;1;EQUIV(H3;$L$10:$P$10;0));0)
Pardonne moi encore mais c'est la formule d'hier ou celle issue du tableur de ce matin?
 

Mustang007

XLDnaute Nouveau
Sinon, pour simplifier, je rentrerai manuellement les paramètres 3-4-5 & 6?
Du coup dans score total, j'aurai juste une formule qui dépendra des paramètres 1 & 2 et j'aurai juste a ajouter les points que j'aurai rentré manuellement?
Votre avis?
 

Discussions similaires

Réponses
6
Affichages
230

Statistiques des forums

Discussions
313 243
Messages
2 096 509
Membres
106 645
dernier inscrit
hf10