Arrondi à un chiffre mais en en affichant 2 ?!!

maryline89

XLDnaute Nouveau
bonjour,

existe t il une formule permettant d'afficher un nombre genre :

2.5687 en 2.60 ?

moi j 'ai fait une formule arrondi a une chiffre et format de cellule personnalisé j'ai mis 0.00

donc ça donne 2.60, ce qui est bon, mais mon patron me dit que ce n'est pas ça, qu'il y a une formule pour faire ça sans passer par la mise en forme...évidement il ne la connait pas mais est sûr qu'une ancienne collègue l'appliquait...

des idées ??

merci d'avance
 

maryline89

XLDnaute Nouveau
Re : Arrondi à un chiffre mais en en affichant 2 ?!!

bonjour,

bien non c'est ce que j'ai fait et donc ça donne 2.57 alors que moi je veux qui m arrondisse a 2.6 mais en mettant un zero apres le 6 de sorte a avoir 2.60, ça fait plus jolie sur les devis ...

merci quand meme
 

hoerwind

XLDnaute Barbatruc
Re : Arrondi à un chiffre mais en en affichant 2 ?!!

Bonjour, salut R@chid et Pierrot93,

Il y aussi : =ARRONDI(A1*10;0)/10 au format 0.00
Bien que la proposition de Pierrot93 est pour moi la meilleure.

Mais que doit renvoyer 2.4487 : 2.60 ou 2.50 ?
Peut-être qu'on y verra plus clair avec plusieurs exemples et les résultats à obtenir
 

maryline89

XLDnaute Nouveau
Re : Arrondi à un chiffre mais en en affichant 2 ?!!

oui mais non, car la on touche au format...alors que selon mon boss :mad: il y a une formule qui existe sans toucher au format...
enfin il y connait rien hein il est juste la pour me casser la tête....
et comme moi je suis têtue j'aime bien aller au bout des choses malgrès que ma formule et mon format de départ fonctionne très bien....
 

Modeste geedee

XLDnaute Barbatruc
Re : Arrondi à un chiffre mais en en affichant 2 ?!!

Bonsour®
En effet ton patron est un con s'il ne sait pas que le deuxieme argument de texte c'est le format !
maintenant, bonjour l'addition des résultats texte !

:rolleyes:
Si... Si... l'addition marchera !!!!
Capture.JPG
ainsi que toute opération mathématique :
1*B1
1+0
--B1
B1*sin(PI()/2)
B1*18.6%

la présence d'un opérateur mathématique et l'utilisation de références unicellulaire provoque l'évaluation de l'élément cible.
alors qu'une fonction et/ou l'utilisation de plage multicellulaire ne le fait pas !!!!
 

Pièces jointes

  • Capture.JPG
    Capture.JPG
    36.8 KB · Affichages: 71
  • Capture.JPG
    Capture.JPG
    36.8 KB · Affichages: 79
  • Capture.JPG
    Capture.JPG
    36.8 KB · Affichages: 76
  • Capture.JPG
    Capture.JPG
    42.5 KB · Affichages: 115
  • Capture.JPG
    Capture.JPG
    42.5 KB · Affichages: 127

Discussions similaires

Statistiques des forums

Discussions
312 927
Messages
2 093 674
Membres
105 781
dernier inscrit
Dominique G.