Additions et soustractions de colonnes selon 2 conditions

DominicBeauce

XLDnaute Nouveau
Bonjour à vous,

Je cherche à calculer dans le tableau ci-joint, combien je dois commander de $$ si je retrouve les 2 conditions suivantes dans mon tableau:

D=12 et E=694. Si ses 2 conditions sont remplies, Faire (H-G+I)*J. Le résultat doit s'afficher dans la cellule Jaune B7.

J'ai essayer depuis quelques jours avec des sommeprod et somme.si mais je n'y arrive pas.

Merci pour votre aide
 

Pièces jointes

  • test.xlsx
    15 KB · Affichages: 46
  • test.xlsx
    15 KB · Affichages: 52
  • test.xlsx
    15 KB · Affichages: 47

vgendron

XLDnaute Barbatruc
Re : Additions et soustractions de colonnes selon 2 conditions

Hello
à mon avis tu avais la solution depuis longtemps. sauf que le format de tes cellules était pas bon.. en colonne A, tes valeurs sont en format texte..

Voir PJ pour exemple et test
 

Pièces jointes

  • Dominic Beauce.xlsx
    14.8 KB · Affichages: 49

DominicBeauce

XLDnaute Nouveau
Re : Additions et soustractions de colonnes selon 2 conditions

Oh effectivement sa fonctionne mieux comme cela ;-) merci

Si on compliquerait le tout... Dans cette formule, je veux que si (H4:H43-G4:G43+I4:I43)*J4:J43)<0;"0".

Je ne veux pas que des quantités négatives viennent baisser le montant à commander. Ya t'il une façon d'intégrer <0;"0" à la sommeprod?

=SOMMEPROD((D4:D43=A7)*(E4:E43=A5);(H4:H43-G4:G43+I4:I43)*J4:J43)
 

vgendron

XLDnaute Barbatruc
Re : Additions et soustractions de colonnes selon 2 conditions

un truc dans le genre:
en fait tu fais la somme si les conditions ()=12 ET ()=694 ET ()>0 sont vérifiées

SOMMEPROD(($D$4:$D$43=A7)*($E$4:$E$43=$A$5)*(($H$4:$H$43-$G$4:$G$43+$I$4:$I$43)*$J$4:$J$43>0);($H$4:$H$43-$G$4:$G$43+$I$4:$I$43)*$J$4:$J$43)
 

Discussions similaires

Statistiques des forums

Discussions
312 896
Messages
2 093 388
Membres
105 716
dernier inscrit
jrmdprt