addition de durée

gibe

XLDnaute Nouveau
bonjour à tous, je vous decouvre !
Je recherche comment dans un tableau excel additionner sur une colonne un grand nombre de durée écrite en heure et centième, exemple : 104 h 39 centième + 57h 78 +251h 42 ect.
Par vance je vous remercie de vos conseils.
bonne journée à tous et @ ++++
 

andré

XLDnaute Barbatruc
Salut,

Je suppose que tes valeurs sont en format texte.

Dans une colonne voisine, la formule :
=(SUBSTITUE(SUBSTITUE(A1;'h';'');' ';'.'))/24 au format [h]:mm:ss transformera les données en format horaire, qu'il suffit dès lors d'additionner.

Le dernier '.' de la formule devra être modifié en ',' si ton séparateur décimal est la , (virgule), chez mois c'est le . (point).

Â+
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Une seule formule pour avoir la somme :
=SOMME(SI(ESTNUM(TROUVE('h';A1:A10));SUBSTITUE(A1:A10;'h ';',')*1))/24
Cellule qui reçoit le résultat : format [hh]:mm

Ou bien résultat au format décimal :
=SOMME(SI(ESTNUM(TROUVE('h';A1:A10));SUBSTITUE(A1:A10;'h ';',')*1))

Formules matricielles, à valider par ctrl, maj et entrée
 

Discussions similaires