Addition de cellules sous MFC

N

Nicolas

Guest
Bonjour,

Comment puis je faire pour additionner des cellules ayant des mFC différentes?

J'ai 2 colonnes différentes où chaque cellule à 2 MFC. j'aurais aimé qu'excel me fasse appraître le total des cellules jaunes (1er MFC) et aussi de manière séparé le total des cellules bleus (2 ème MFC).

Est-ce possible? existe-t-il une formule?

Vous remerciant

Cordialement

Nicolas
 

Tibo

XLDnaute Barbatruc
Resalut Nicolas,

Il faut passer dans ce cas par la fonction SOMMEPROD.

A essayer :

=SOMMEPROD((plage>15)*plage)

Dans ce cas, j'ai pris comme critère '>15'

A adapter à ton critère.

Reviens avec le fichier si problème


Bonne soirée.

@+
 
N

Nicolas

Guest
Re salut,

a quoi correspond le critère >15?

Pour ma part mes différentes MFC servent de comparaison de textes. elles reconnaissent les nouveaux noms et les noms disparus par rapport à une colonne de référence d'où la formule NB.SI.

Cependant j'aimerais pouvoir additionner les cellules des différentes MFC. c'est pour cela que je ne comprends pas le critère à remplacer.

te remerciant.
 

Tibo

XLDnaute Barbatruc
Salut Nicolas,

J'avais pris comme exemple de prendre en compte dans la plage les cellules dont le montant était supérieur à 15 (c'était un simple exemple).

Pour répondre précisément à ton problème, il nous faut ton fichier (sans données confidentielles).

Pour joindre ton fichier, suis les conseils de ce tutoriel :

Lien supprimé

Bonne soirée

@+
 
N

Nicolas

Guest
merci pour ta réponse. je te joins mon fichier [file name=Classeur1_20051114202731.zip size=2308]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur1_20051114202731.zip[/file]
 

Pièces jointes

  • Classeur1_20051114202731.zip
    2.3 KB · Affichages: 36

Tibo

XLDnaute Barbatruc
Salut Nicolas,


Je te joins un début de réponse avec la fonction SOMMEPROD.

Tu pourras t'en inspirer pour aller plus loin (je bloque sur les cellules rouges).

La fonction SOMMEPROD est très puissante, mais pose parfois des problèmes de maîtrise.

Peut-être d'autres forumeurs te trouveront la solution.

Je continue quand même à chercher.


@+

[file name=Nico_sommeprod.zip size=2468]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Nico_sommeprod.zip[/file]
 

Pièces jointes

  • Nico_sommeprod.zip
    2.4 KB · Affichages: 35

Tibo

XLDnaute Barbatruc
Resalut Nico,

Je viens de revérifier, les formules que j'ai mis pour les cellules jaunes ne fonctionnent pas.

J'avoue que je bloque sur cette fonction SOMMEPROD.

Maîtriser cette fonction se mérite sans doute...

Pour moi, c'est encore dur dur.

Peut-être un passage de Monique pourrait te sortir de cette impasse...


Bonne soirée

@+
 

Monique

Nous a quitté
Repose en paix
Bonjour,

J'ai modifié la mise en forme conditionnelle
Au lieu de
=NB.SI($A$4:$A$17;B4)=1
c'est maintenant
=NB.SI($A$4:$A$17;B4)>0
ou bien la même chose en plus court :
=NB.SI($A$4:$A$17;B4)

Le nb de couleurs
La 1ère couleur
=SOMMEPROD(NB.SI($A$4:$A$17;$D$4:$D$17))
La 2ème
=SOMMEPROD((NB.SI($A$4:$B$17;$D$4:$D$17)>0)-(NB.SI($A$4:$A$17;$D$4:$D$17)>0))
La 3ème
=SOMMEPROD((NB.SI($A$4:$C$17;$D$4:$D$17)>0)-(NB.SI($A$4:$B$17;$D$4:$D$17)>0))

En fait, dans la MEFC, la 2ème couleur ne se met en place que si le 1ère condition n'est pas réalisée
et la 3ème ne se met en place que si aucune des 2 premières n'est réalisée

Je ne sais pas si ça marche à tous les coups,
tu vérifieras.
[file name=SommeProdNico.zip size=3917]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/SommeProdNico.zip[/file]
 

Pièces jointes

  • SommeProdNico.zip
    3.8 KB · Affichages: 33
N

Nicolas

Guest
Re,

Merci monique, tout cela semble fonctionner mais j'ai un peu de mal avec la première couleur avec SOMMEPROD. cela marche très bien avec peu de valeur mais après cela plante un peu, mais je me suis arrangé.

Pour l'addition des MFC, est-il possible de les additionner sans tenir compte des doublons. j'ai essayé la formule SOMMEPROD (1/nb.SI(plage;plage)), mais cela m'affiche une valeur DIVO.

donc je ne sais pas si cela est possible

Cordialement
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Je n'y arrive pas sans passer par un tableau intermédiaire qui élimine les doublons.
(tu peux le mettre dans une autre feuille)
[file name=SommeProdNicoV1.zip size=5715]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/SommeProdNicoV1.zip[/file]
 

Pièces jointes

  • SommeProdNicoV1.zip
    5.6 KB · Affichages: 43

Discussions similaires

Statistiques des forums

Discussions
300 793
Messages
1 987 226
Membres
209 741
dernier inscrit
Reda061