XL 2019 [VBA][Résolue] Insérer une formule RechercheV dans une cellule en VBA au sein d'une boucle.

Kyirra

XLDnaute Nouveau
Salut à tous,

Je cherche un moyen de faire en sorte qu'une cellule prenne en valeur une recherchev en vba.

Si je l'intègre comme ca :

worksheets("Feuil1").Range("H4") = "=RECHERCHEV(G4;A3:B5;2;FAUX)"

tout fonctionne aucun soucis

par contre dans le cas ou je veux faire en sorte que les valeur de mes lignes changes et donc que je rentre une variable à la place comme ceci :

Sub test()

Iteration = 4

worksheets("Feuil1").Range("H"&iteration) = "=RECHERCHEV(G"&iteration&";A3:B5;2;FAUX)"

End Sub


Je me retrouve avec une "erreur de compilation, fin d'instruction demandée" sur la ligne.... je ne comprend pas pourquoi tous les guillemets sont bien passé.....
 

Pièces jointes

  • test.xlsm
    12.8 KB · Affichages: 6

Discussions similaires

Réponses
1
Affichages
279

Statistiques des forums

Discussions
299 943
Messages
1 980 253
Membres
207 040
dernier inscrit
Lefebvre JL