XL 2010 Valeur SI imbriquée combinée à une RECHERCHE

Orson83

XLDnaute Impliqué
Je suis nouveau sur le Forum et je vous salut à tous.

Voici ma problématique:

Je conçois un devis qui doit prendre en compte les différents codes de TVA (1=20%, 2=5,5%, 3=0%) afin d'obtenir la valeur des différentes TVA.

J'ai donc 3 colonnes (déjà renseignées) :

- Colonne 1 nommée codetva= mes codes TVA 1, 2 ou 3
- Colonne 2 nommée colonneht = mon total HT, résultat à la ligne
- Colonne 3 nommée colonnettc = mon total TTC, résultat à la ligne

Problème : Si dans la colonne 1 codetva je trouve le code 1, alors j'additionne le total de ma colonne 2 colonnettc moins le total de ma colonne 3 colonneht (je devrais obtenir la valeur de la TVA 1... normalement).

Idem pour la TVA 2 et la TVA 3.

Voici ce que j'ai essayé mais je pense qu'il faut y inclure une recherche :

=SI(codetva=1;SOMME(colonnettc)-SOMME(colonneht);
SI(codetva=2;SOMME(colonnettc)-SOMME(colonneht);
SI(codetva=3;SOMME(colonnettc)-SOMME(colonneht);0)))

Pas de VBA s'il vous plait, mon classeur doit rester en Excel 2010 .xlsx

Merci pour votre aide.
 

Victor21

XLDnaute Barbatruc
Bonsoir, Tchotchodu31

Un court fichier Excel en exemple, en plus de nous indiquer comment vos données sont organisées, nous permettrait de tester nos éventuelles propositions avant de vous les soumettre, sans nous obliger à tenter de le recréer.
@Tchotchodu31 : A relire votre post, que le code TVA soit 1, 2 ou 3, le TTC-le HT donnera toujours le montant de la TVA.
 
Dernière édition:

Victor21

XLDnaute Barbatruc
Re,

Pour les 20% : =SOMMEPROD(($G$17:$G$61=1)*$I$17:$I$61)*20%
Pour les 5.5% : =SOMMEPROD(($G$17:$G$61=2)*$I$17:$I$61)*5.5%
Le montant total de TVA à 0% me semble superflu :)
Attention : le total HT prend en compte les montants TTC.
En I64, mettez : =SOMME(I17:I61)
 

Statistiques des forums

Discussions
313 281
Messages
2 096 785
Membres
106 748
dernier inscrit
Abdel93