Microsoft 365 Transformer le résulta d'une formule en Date

Nathan027

XLDnaute Junior
Bonjour à toutes et à tous.

Je vous explique ma demande.
J'ai mis une formule dans une cellule qui reprendre le nom d'un fichier.
Le nom du fichier est 01.02.2024
J'ai dans une cellule (D5) écris cette formule :
=SUBSTITUE((STXT(CELLULE("nomfichier");CHERCHE("[";CELLULE("nomfichier"))+1;CHERCHE("]";CELLULE("nomfichier"))-CHERCHE("[";CELLULE("nomfichier"))-6));".";"/")

Ainsi le texte dans la cellule devient : 01/02/2024
Pour les besoin de mon fichier, j'aimerai que ce texte soit une date pour que je puisse m'en servir dans une RECHERCHEV que j'utilise dans une autre cellule(G5)
=RECHERCHEV($D$5;'Calendrier posté'!$B$10:$C$375;2;FAUX)

Je vous joint mon fichier :)

J'espère que vous pourrez m'aider. Un grand merci d'avance.
 

Pièces jointes

  • 01.02.2024.xlsm
    54.2 KB · Affichages: 3
Solution
Bonjour à toutes et à tous.

Je vous explique ma demande.
J'ai mis une formule dans une cellule qui reprendre le nom d'un fichier.
Le nom du fichier est 01.02.2024
J'ai dans une cellule (D5) écris cette formule :
=SUBSTITUE((STXT(CELLULE("nomfichier");CHERCHE("[";CELLULE("nomfichier"))+1;CHERCHE("]";CELLULE("nomfichier"))-CHERCHE("[";CELLULE("nomfichier"))-6));".";"/")

Ainsi le texte dans la cellule devient : 01/02/2024
Pour les besoin de mon fichier, j'aimerai que ce texte soit une date pour que je puisse m'en servir dans une RECHERCHEV que j'utilise dans une autre cellule(G5)
=RECHERCHEV($D$5;'Calendrier posté'!$B$10:$C$375;2;FAUX)

Je vous joint mon fichier :)

J'espère que vous pourrez m'aider. Un...

Gégé-45550

XLDnaute Accro
Bonjour à toutes et à tous.

Je vous explique ma demande.
J'ai mis une formule dans une cellule qui reprendre le nom d'un fichier.
Le nom du fichier est 01.02.2024
J'ai dans une cellule (D5) écris cette formule :
=SUBSTITUE((STXT(CELLULE("nomfichier");CHERCHE("[";CELLULE("nomfichier"))+1;CHERCHE("]";CELLULE("nomfichier"))-CHERCHE("[";CELLULE("nomfichier"))-6));".";"/")

Ainsi le texte dans la cellule devient : 01/02/2024
Pour les besoin de mon fichier, j'aimerai que ce texte soit une date pour que je puisse m'en servir dans une RECHERCHEV que j'utilise dans une autre cellule(G5)
=RECHERCHEV($D$5;'Calendrier posté'!$B$10:$C$375;2;FAUX)

Je vous joint mon fichier :)

J'espère que vous pourrez m'aider. Un grand merci d'avance.
Bonjour,
supposons que votre formule figure en A1, il suffit d'écrire dans une cellule libre la formule suivante :
VB:
=DATEVAL(A1)
ou d'écrire dans A1 :
VB:
=DATEVAL(SUBSTITUE((STXT(CELLULE("nomfichier");CHERCHE("[";CELLULE("nomfichier"))+1;CHERCHE("]";CELLULE("nomfichier"))-CHERCHE("[";CELLULE("nomfichier"))-6));".";"/"))
Cordialement,
 

Discussions similaires

Réponses
16
Affichages
777

Statistiques des forums

Discussions
312 534
Messages
2 089 381
Membres
104 151
dernier inscrit
CMB