XL 2016 Transfert suivant deux critère

Seddiki_adz

XLDnaute Impliqué
bonjour
j'ai besoin d'aide pour transfert des donnes de l'onglet BDD vers feuil2 suivant les deux critère la date et matin ou soir
Merci d'avance
 

Pièces jointes

  • essaie2.xlsm
    20.6 KB · Affichages: 6
Dernière édition:
Solution
Bonjour Seddiki_adz,
Un exemple en PJ avec cette formule :
VB:
=SI($F$10="matin";INDEX(BDD!$1:$1048576;EQUIV($B14;BDD!$A:$A;0);
EQUIV($C$10;BDD!$1:$1;0));INDEX(BDD!$1:$1048576;EQUIV($B14;BDD!$A:$A;0);5+EQUIV($C$10;BDD!$1:$1;0)))
Pour matin et soir on rajoute +3 sur le N° de colonne, pour p1,p2,p3 on rajoute encore +0,+1,+2 sur le N° de colonne.

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Seddiki_adz,
Un exemple en PJ avec cette formule :
VB:
=SI($F$10="matin";INDEX(BDD!$1:$1048576;EQUIV($B14;BDD!$A:$A;0);
EQUIV($C$10;BDD!$1:$1;0));INDEX(BDD!$1:$1048576;EQUIV($B14;BDD!$A:$A;0);5+EQUIV($C$10;BDD!$1:$1;0)))
Pour matin et soir on rajoute +3 sur le N° de colonne, pour p1,p2,p3 on rajoute encore +0,+1,+2 sur le N° de colonne.
 

Pièces jointes

  • essaie2.xlsm
    20.6 KB · Affichages: 6

Discussions similaires

Réponses
40
Affichages
2 K
Réponses
6
Affichages
206

Statistiques des forums

Discussions
312 799
Messages
2 092 239
Membres
105 298
dernier inscrit
doudounapnap