test sur cellules non vides

  • Initiateur de la discussion Pascal
  • Date de début
P

Pascal

Guest
Salut,

J'aimerais copier des feuilles Excel dans un nouveau classeur uniquement si les cellules A3 a A30 ne sont pas vides. Pourriez-vous m'aider à faire ca?
Je pense que ca doit ressembler à:

"for cellules A3:A30 NON VIDES, do Worksheet.Copy Before:=Workbooks(Workbooks.Count).Sheets(1)".

Le probleme c'est que je ne sais pas comment dire à Excel de chercher des cellules non vides.

Merci de votre aide.
 
P

Pascal

Guest
Merci Leatitia,

J'avais effectivement cherché sur le forum, mais comme je débute avec VBA, j'avais du mal à l'adapter sur mon exemple.

Je pensais à inserer une formule dans une cellule inutilisée et invisible (disons O1):

=SI(NB.VIDE(A3:A30)=28;"VRAI";"FAUX")

et ensuite faire une boucle if sur cette cellule

If Range("O1").Value = "Vrai" Then
end sub
Else: Worksheets("nomdemafeuille").Copy Before:=Workbooks(Workbooks.Count).Sheets(1)
End If

Bon ca fait un peu bricolage mais je pense pouvoir m'en sortir...Merci encore!
 

Discussions similaires

Statistiques des forums

Discussions
312 842
Messages
2 092 738
Membres
105 519
dernier inscrit
faivre-roussel.ivan@orang