Microsoft 365 Somme décaler débutant à la 1ère valeur

raf26

XLDnaute Occasionnel
Bonjour le forum,

J'ai (à nouveau) besoin de vos compétences.

Je ne trouve pas la bonne formule pour sommer les n premières ventes de chaque mois.

J'ai essayer avec la formule décaler, la somme débute le 1er du mois, mais certains mois, la 1ère vente a lieu le 2 ou le 3 (voir capture ci-dessous et fichier joint)




capture-decran-2022-04-11-a-19-57-57-jpg.1136595


Je vous joins un fichier exemple

Pas de macro car le fichier sera partagé via OneDrive.

Je vous remercie par avance de vos contributions.

Cordialement
 

Pièces jointes

  • Capture d’écran 2022-04-11 à 19.57.57.jpg
    Capture d’écran 2022-04-11 à 19.57.57.jpg
    89.6 KB · Affichages: 73
  • Classeur1.xlsx
    13.6 KB · Affichages: 3

JHA

XLDnaute Barbatruc
Bonjour à tous,

Avec une colonne supplémentaire sur chaque mois et sommeprod
VB:
=SOMMEPROD((ESTNUM(DECALER($A$6;1;EQUIV($R9;$A$6:$N$6;0);31)))*(DECALER($A$6;1;EQUIV($R9;$A$6:$N$6;0)+1;31)<=$U$4);DECALER($A$6;1;EQUIV($R9;$A$6:$N$6;0);31))

JHA
 

Pièces jointes

  • Classeur1 (10).xlsx
    15.8 KB · Affichages: 2

Hasco

XLDnaute Barbatruc
Repose en paix
Bonjour,

Puisque excel 365, j'ai testé avec les nouvelles fonctions (améliorable peut-être):
=LET(Datas;RECHERCHEX($N9;$A$6:$I$6;B$7:J$37);
Datas2;FILTRE(Datas;Datas<>"");
CPT; SI(LIGNES(Datas2)<$Q$4;LIGNES(Datas2);$Q$4);
SIERREUR(SOMME( INDEX(Datas2;SEQUENCE(CPT;;;1)));0))
Hello @JHA

Cordialement
 

Pièces jointes

  • Classeur1 (1).xlsx
    19.6 KB · Affichages: 3

raf26

XLDnaute Occasionnel
Bonsoir JHA et Hasco

Je vous remercie de vous être penchés sur mon problème.

Vos 2 solutions me conviennent parfaitement, merci à vous.

Je note celle de Hasco en "résolu" (plus simple pour moi, cela m'évite l'ajout de colonnes)

Encore merci !!
 

Discussions similaires

Statistiques des forums

Discussions
312 947
Messages
2 093 839
Membres
105 851
dernier inscrit
aviato