somme C-B, mais si C-B<0 = 0?

zitoune555

XLDnaute Junior
Bonjour
je viens d'essayer plusieurs formules pour comparer les valeurs de deux cellules C et B.

si B est supérieur à C (donc résultat négatif) je souhaite que le résultat soit égal à zéro.
mais les trois formules que j'ai éssayé ne vont pas.

=SOMME(C3-B3);;SI(C3>0;D3="") ou
=SOMME(C3-B3);SI(ET(C3>B3;D3="");(C3<B3;D3=0))
et =SOMME(C3-B3);SI(C3-B3<0);0

espérant être clair.
pouvez vous me dire ce qu'il faut que je fasse?
merci de votre attention
 

ROGER2327

XLDnaute Barbatruc
Re : somme C-B, mais si C-B<0 = 0?

Bonjour à tous


Deux autres :​
Code:
=(C3-B3)*(C3>B3)
Code:
=(C3-B3+ABS(C3-B3))/2
À noter que cette dernière est purement arithmétique : ni test de comparaison, ni fonction Max.​


ROGER2327
#6277


Mercredi 11 Sable 140 (Nativité de Saint Grabbe, scherziste - fête Suprême Quarte)
21 Frimaire An CCXXI, 5,8977h - érable à sucre
2012-W50-2T14:09:16Z
 

Discussions similaires

Réponses
5
Affichages
174

Statistiques des forums

Discussions
312 932
Messages
2 093 730
Membres
105 802
dernier inscrit
Witchun