Selectionner par Macro les Données Filtrées

ljoue

XLDnaute Junior
Bonjour à tous,

J'ai un tableau où je filtre les données par Mois (colonne H).

Une fois le Filtrage effectué, j'aimerais pouvoir par Macro sélectionner ces données pour les copier sur une autre feuille nomée 'Liste Finale'
Le nombre de données varient d'un mois à l'autre il me faut donc une sélection dynamique.

En gros ne sélectionner que ce qui est visible sur la fenêtre !


Merci d'avance pour votre aide...

Cordialement,
Laurent
 

Staple1600

XLDnaute Barbatruc
Bonjour


Une première approche

Sub Macro2()
z = InputBox('Mois sélectionné?', 'Choix du mois')
Application.ScreenUpdating = False
Range('B1').Select
Selection.AutoFilter
Selection.AutoFilter Field:=2, Criteria1:=z
Selection.CurrentRegion.Select
Selection.Copy
Sheets('Liste Finale').Select
Range('A1').Select
ActiveSheet.Paste
Sheets('Feuil1').Select
Application.CutCopyMode = False
Selection.AutoFilter
End Sub

colonne A contient des dates
en colonne B: =TEXTE(A1;'mmmm')
 

ljoue

XLDnaute Junior
Staple1600 écrit:
Selection.CurrentRegion.Select
Selection.Copy
Sheets('Liste Finale').Select
Range('A1').Select
ActiveSheet.Paste
Sheets('Recup NAV').Select
Application.CutCopyMode = False
Selection.AutoFilter
End Sub
Trop bon c'est exactement ce bout de code que je cherchais !
Merci à toi Staple1600 ;)


Code Allégé :
Selection.AutoFilter Field:=8, Criteria1:=Range('B1').Value
Selection.CurrentRegion.Copy
ActiveSheet.Paste Destination:=Worksheets('Liste Finale').Range('A5')
Selection.AutoFilter
Application.CutCopyMode = False


@+
 

Discussions similaires

Réponses
26
Affichages
579

Statistiques des forums

Discussions
312 930
Messages
2 093 717
Membres
105 794
dernier inscrit
mallet