XL 2013 (RESOLU) Copier plusieurs colonnes

chaelie2015

XLDnaute Accro
Bonjour forum
Comment puis-je copier les données de la ligne jaune (par exemple 50 COLONNE), y compris leurs formules, dans la ligne verte (qui est une cellule fusionnée 2X50 COLONNES)?
Merci
 

Pièces jointes

  • Charlie copier formule cel fusionnée.xlsx
    76.6 KB · Affichages: 7
Solution
Re,
Cela revient en AO64 de faire "=GL64", on peut donc faire pour tenir compte des cellules fusionnées :
VB:
Sub ColleFormule()
For C = 41 To 140 Step 2
    Cells(64, C).FormulaLocal = "=INDEX(64:64;0.5*COLONNE()+173.5)"
Next C
End Sub

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Chaelie,
1- Cette formule en GL64 :
VB:
=SOMME(GL13:GL62)
Copiée en AO64 doit elle être :
Code:
=SOMME(AO13:AO62)
ou
=SOMME(AO13:AP62)
Doit on faire la somme d'une colonne ou des deux colonnes pour lesquelles les cellules vertes sont fusionnées ?
2- Cette formules es elle immuable ou est elle appelée à changée ?
Car si la formule est immuable, on peut faire :
Code:
Sub Formule()
    Range("AO64:AP64").FormulaLocal = "=SOMME(AO13:AO62)"
    Range("AO64:AP64").Copy
    Range("AO64:EJ64").Select
    Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
        SkipBlanks:=False, Transpose:=False
End Sub
Si la formule peut changer, alors on peut faire :
VB:
Sub Formule()
    Range("GL64").Copy
    Range("AO64:AP64").Select
    Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
        SkipBlanks:=False, Transpose:=False
    Range("AO64:AP64").Copy
    Range("AO64:EJ64").Select
    Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
        SkipBlanks:=False, Transpose:=False
End Sub
 

chaelie2015

XLDnaute Accro
Bonjour sylvanu
Je désire reproduire toutes les formules de la ligne jaune, telles que SOMME(GL13:GL62), SOMME(GM13:GM62), SOMME(GN13:GN62), etc., jusqu'à SOMME(II13:IIL62), dans les cellules de la ligne verte, c'est-à-dire la cellule fusionnée AO64=SOMME(GL13:GL62), AQ64=SOMME(GM13:GM62), et ainsi de suite.
Nota : avec formule
A+
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Cela revient en AO64 de faire "=GL64", on peut donc faire pour tenir compte des cellules fusionnées :
VB:
Sub ColleFormule()
For C = 41 To 140 Step 2
    Cells(64, C).FormulaLocal = "=INDEX(64:64;0.5*COLONNE()+173.5)"
Next C
End Sub
 

Pièces jointes

  • Charlie copier formule cel fusionnée (1).xlsm
    81.6 KB · Affichages: 2

Discussions similaires

Réponses
20
Affichages
440
Réponses
3
Affichages
175

Membres actuellement en ligne

Statistiques des forums

Discussions
313 283
Messages
2 096 813
Membres
106 752
dernier inscrit
Tahiri1976