RechercheV & Stxt

Laura97X

XLDnaute Nouveau
Bonjour à tous,

je vais essayer d'être claire dans mon pb :)

J'essaye de faire une recherchev par rapport à 1 ou 2 caractères compris dans une cellule, je fais donc la formule suivante !

=RECHERCHEV((STXT(A26;1;1));Statut!A2:D10;4;FAUX)

mais ça ne fonctionne pas :confused:

Quelqu'un pour m'aider svp???




Edit : rebonjour,
merci pour vos réponse !
j'ai une autre question consécutive à la première
dans le fichier que je vais joindre, je voudrais que la colonne B, apparaisse la réponse de la colonne C à F mais dans la meme cellule

je voudrais donc qu'en B3 apparaissent :
occasion neuf deprecié pucci femme stylise

je vais, par la suite pouvoir supprimer les colonnes de C à F

Merci d'avance pour vos réponses
 
Dernière édition:

Laura97X

XLDnaute Nouveau
Re : RechercheV & Stxt

ok
ci joint le fichier

j'ai enlever beaucoup d'onglets mais ça ne devrait pas poser de soucis pour mon pb

merci d'avance
 

Pièces jointes

  • help please.xls
    37 KB · Affichages: 110
  • help please.xls
    37 KB · Affichages: 108
  • help please.xls
    37 KB · Affichages: 109

Raja

XLDnaute Accro
Re : RechercheV & Stxt

Bonjour,

Si je comprends bien, essaye la formule suivante :

Code:
=RECHERCHEV((STXT(A3;1;1));Statut!B2:D10;3;FAUX)

Car, la valeur cherchée(1er paramètre de la formule) doit être dans la première colonne de la matrice de recherche(2è paramètre de la formule).
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re : RechercheV & Stxt

Bonjour le Forum,
Bonjour Laura97X, ballmaster,

La plage de recherche doit commencée en colonne B

=RECHERCHEV((STXT(A3;1;1));Statut!B2:D10;3;FAUX)

autre solution qui t'éviteras d'avoir une colonne D en feuille statut puisquelle permet d'aller chercher les infon a gauche de la colonne ou l'on cherche :

=INDEX(Statut!A:A;EQUIV(GAUCHE(A3);Statut!B:B;0))

Jocelyn

Oup's Bonjour raja, désolé pour la collision
 

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 313
dernier inscrit
tissouma