XL 2019 Recherche formule pour chercher le meme caractère entre deux cellules

Guillaumeg3

XLDnaute Junior
Bonjour à tous,

Je viens vers vous cette fois si car je n'arrive pas à trouver la bonne formule pour le cas suivant
Si entre A1 et B1 j'ai le premier mot qui est le même alors B1
Si non A1&" "&B1
Petite difficulté : Si en A1 j'ai d'autres caractères après le premier mot alors on les supprime.

J'ai mis un fichier exemple pour que cela soit plus clair.

Merci à vous
 

Pièces jointes

  • EXEMPLE.xlsx
    8.9 KB · Affichages: 4

JHA

XLDnaute Barbatruc
Bonjour à tous,

En "C2"
VB:
=SI(SIERREUR(STXT($B2;1;CHERCHE(" ";$B2)-1);$B2)=SIERREUR(STXT($A2;1;CHERCHE(" ";$A2)-1);$A2);$B2;SIERREUR(STXT($A2;1;CHERCHE(" ";$A2)-1);$A2)&" "&$B2)
copier vers le bas

JHA
 

Pièces jointes

  • EXEMPLE.xlsx
    9.5 KB · Affichages: 2

Guillaumeg3

XLDnaute Junior
Merci Beaucoup JHA!

C'est exactement ce que je cherché.

Je me permets d'utiliser ce post pour une autre question.
Est ce qu'il y aurait une petite formule VBA afin de supprimer toutes les lignes en dessous de mon tableau ?
En ce moment j'en ai plus de 10 000 mais dans la navigation je suis à plus de 1 000 000 rendant le défilement pénible
 

Discussions similaires

Réponses
10
Affichages
453

Statistiques des forums

Discussions
312 894
Messages
2 093 379
Membres
105 712
dernier inscrit
CARLO 82