XL 2021 Recherche d'une formule pour trouver la valeur la moins représentée dans une plage

bourcier1952

XLDnaute Nouveau
Bonjour,
Je recherche une formule pour trouver la valeur la moins représentée dans une plage. Merci de votre aide. Patrick.
 

job75

XLDnaute Barbatruc
Bonsoir bourcier1952, [edit] bonsoir djidji59430,

Si la plage à étudier est nommée plage utiliser :
Code:
=JOINDRE.TEXTE(" ; ";VRAI;SI(NB.SI(plage;plage)=MIN(NB.SI(plage;plage));plage;""))
C'est une formule matricielle mais sur Excel 2021 la validation matricielle n'est pas nécessaire.

A+
 
Dernière édition:

bourcier1952

XLDnaute Nouveau
Bonjour à tous,

essaye
=INDEX(E1:E4;EQUIV(MIN(NB.SI(E1:E4;E1:E4));NB.SI(E1:E4;E1:E4);0))

E1:E4 plage des valeurs
S'il y a des exæquos, c'est la première valeur qui est affichée

Crdlmt
Merci beaucoup de ta réponse.
Petite difficulté supplémentaire : dans la plage, je souhaiterai ignorer les cellules vides.
Comment dois-je modifier la formule pour y parvenir ?
Merci d'avance.
Patrick
 

job75

XLDnaute Barbatruc
Bonjour le forum,

La concaténation des ex-aequo ne vous intéresse pas ?

Voici la formule pour éliminer les cellules vides :
Code:
=SIERREUR(JOINDRE.TEXTE(" ; ";VRAI;SI(NB.SI(plage;plage)=PETITE.VALEUR(SI(NON(ESTVIDE(plage));NB.SI(plage;plage));1);plage;""));"")
A+
 

Pièces jointes

  • Classeur(1).xlsx
    9.1 KB · Affichages: 5

bourcier1952

XLDnaute Nouveau
Bonjour le forum,

La concaténation des ex-aequo ne vous intéresse pas ?

Voici la formule pour éliminer les cellules vides :
Code:
=SIERREUR(JOINDRE.TEXTE(" ; ";VRAI;SI(NB.SI(plage;plage)=PETITE.VALEUR(SI(NON(ESTVIDE(plage));NB.SI(plage;plage));1);plage;""));"")
A+
Merci beaucoup de tes réponses.
Petite précision : je n'ai pas besoin de toutes les valeurs les plus faibles concaténées mais uniquement de la valeur la plus faible. Quelle serait alors la formule ? Merci.
 

Discussions similaires

Réponses
2
Affichages
437

Statistiques des forums

Discussions
313 208
Messages
2 096 233
Membres
106 540
dernier inscrit
Piehas