recherche à plusieurs conditions

jacfld49

XLDnaute Occasionnel
bonsoir le forum,

dans mon fichier joins, j'ai une formule avec recherche pour trouver une conditions mais je n'arrive pas à trouver la solutions pour faire une recherche sur plusieurs conditions.J'ai essayé avec index equiv mais j'ai du me tromper car cela me mets nom#.
je joins un fichiers pour mieux m'expliquer.
merci
 

Pièces jointes

  • Copie de PLJOUR32 equipe1 .zip
    29 KB · Affichages: 41
  • Copie de PLJOUR32 equipe1 .zip
    29 KB · Affichages: 44
  • Copie de PLJOUR32 equipe1 .zip
    29 KB · Affichages: 41

abcd

XLDnaute Barbatruc
Re : recherche à plusieurs conditions

Bonjour,

Pas sur d'avoir compris, mais essaie toujours ceci en PLJOUR2!U9 :
=SI(B9="";"";RECHERCHEV(B9;BDPLJR2!A$15:G$34;7))
formule à copier vesr le bas

J'obtiens les mêmes résultats, sans le message d'erreur.
Si ce n'est pas cela, soit quelque peu plus explicite.

abcd
 

JHA

XLDnaute Barbatruc
Re : recherche à plusieurs conditions

Bonsoir JACFLD; le forum,

Une piste avec sommeprod en U9:
=SI(OU(G9<>"";K9<>"");SOMMEPROD((BDPLJR2!B14:B34=BDPLJR2!B39)*(BDPLJR2!G14:G34));"")

Edit:Oups! oublié de figer les references
=SI(OU(G9<>"";K9<>"");SOMMEPROD((BDPLJR2!$B$14:$B$34=BDPLJR2!B39)*(BDPLJR2!$G$14:$G$34));"")

JHA
 
Dernière édition:

Denis132

XLDnaute Impliqué
Re : recherche à plusieurs conditions

Bonjour jacfld49, abcd, JHA,

Tu écris "savoir si l'apprêt est dans la colonne G ou K", mais tu as des nombres d'inscrit dans les deux colonnes. Qu'est-ce qui nous dis lequel tu veux obtenir?

@+

Denis
 

jacfld49

XLDnaute Occasionnel
Re : recherche à plusieurs conditions

salut denis, le forum,

Oui, tu as raison, j'ai des données dans les 2 colonnes car en fait si dans la colonne I de PLJOUR2,c'est ecris PR,alors c'est la colonne K de BDPLJR2 qu'il faut prendre autrement ce sera la colonne G de BDPLJR2.
merci
 

jacfld49

XLDnaute Occasionnel
Re : recherche à plusieurs conditions

bonjour le forum,Denis132,abcd,

merci à vous 2 car les 2 formules fonctionnent très bien.
je voulais savoir quelle différence il y a entre recherche et recherchev car moi j'ai essayé avec recherche et cela ne fonctionnait pas.
merci
 

Discussions similaires

Statistiques des forums

Discussions
312 947
Messages
2 093 843
Membres
105 852
dernier inscrit
Bast