recap heures par semaine

amocco

XLDnaute Occasionnel
Bonjour le forum ,

j ai un peu de mal a faire une recap de mes heures par semaine ,
ci-joint le fichier , + explicite
merci
 

Pièces jointes

  • TEST.xls
    43.5 KB · Affichages: 130
  • TEST.xls
    43.5 KB · Affichages: 132
  • TEST.xls
    43.5 KB · Affichages: 137

abcd

XLDnaute Barbatruc
Re : recap heures par semaine

Bonjour,

Sauf pour M2 ( → 18 ???) :

L2 : =MOD(I2-H2;1)+MOD(K2-J2;1)
M2 : =N2*24 au format nombre 0.00

La somme par semaine :
N2 : =SI(JOURSEM(A2)=1;SOMME(L$1:L1)-SOMME(N$1:N1);"")
cellule au format [hh]:mm
à copier vers le bas.

Edition : je n'avais pas vu te feuille Recap !



abcd
 

amocco

XLDnaute Occasionnel
Re : recap heures par semaine

merci beaucoup pour votre aide
encore une petite question , est il possible avec une liste deroulante d'afficher la recap par employée par exemple .
si je rajoute dans la feuille grille en colonne N les noms des employés par exemple A , B ou c
et que la feuille recap , une liste deroulante qui , en fonction de l'employé choisi affiche sa recap heure
 

mth

XLDnaute Barbatruc
Re : recap heures par semaine

bonsoir amocco,
et bonsoir aux couche-tard :)

Ci-joint un essai à partir de ton fichier avec une liste déroulante et quelques explications.

La formule utilisée est celle suggérée par abcd, avec simplement un critère de plus pour intégrer le choix de l'employé.

Bonne soirée,

mth
 

Pièces jointes

  • TEST(1).zip
    13.6 KB · Affichages: 66
  • TEST(1).zip
    13.6 KB · Affichages: 61
  • TEST(1).zip
    13.6 KB · Affichages: 62

jpp1961

XLDnaute Junior
Re : recap heures par semaine

Et pourquoi pas un tableau croisé dynamique. voir fichier joint

j'ai rectifié la mise en forme conditionnel pour que les jours fériés se grisent automatiquement, et les lundis en rose comme tu avait prévu mais il y avait des guillemets en trop.
 

Pièces jointes

  • TEST avec tableau dynamique.zip
    27.5 KB · Affichages: 40

mth

XLDnaute Barbatruc
Re : recap heures par semaine

re- bonsoir amocco

un dernier petit fichier avant d'aller @dodo.com

J'ai continué à décliner les sommeprod dans ton nouveau tableau par mois, mais l'idée de jpp1961 est vraiment intéressante, et particulièrement adaptée me semble-t-il pour ton récap mensuel, du coup, pas pu résister ;) je t'ai quand même mis un TCD à coté de ton tableau (à compléter si cela t'inspire car je n'ai pas mis tous les champs, c'est juste pour avoir un aperçu)

Pour ta formule en colonne S de l'onglet planning, j'ai juste ajouté un test avec la fonction ESTNA, je te laisse voir si cela te convient.

Bonne nuit à toi et à l'équipe de nuit du forum :)

mth
 

Pièces jointes

  • test2.zip
    29.5 KB · Affichages: 53
  • test2.zip
    29.5 KB · Affichages: 59
  • test2.zip
    29.5 KB · Affichages: 56

amocco

XLDnaute Occasionnel
Re : recap heures par semaine

bonjour le forum
c est vraiment du bon boulot ,
les 2 etudes sont tres interressante
je suis en train de regarder le fonctionnement du tableau dynamique
par contre comment faire pour compter le nombre de "M" EN B31 par exemple
merci mille fois
 

abcd

XLDnaute Barbatruc
Re : recap heures par semaine

Bonjour,

Je suppose que c'est en RECAP!B31 que tu veux compter les M dans les colonnes G et H de la feuille PLANNING!

=SOMMEPROD((PLANNING!$C$4:$C$130=B$23)*(PLANNING!$G$4:$H$130=$B31))
à copier vers la droite, ce qui donne 58 pour février et 32 pour mars.

abcd
 

Discussions similaires

Réponses
5
Affichages
376

Statistiques des forums

Discussions
312 922
Messages
2 093 644
Membres
105 774
dernier inscrit
Tibenjah