Probleme de format de cellulle

martin sthilaire

XLDnaute Nouveau
Bonjour, j'ai besoin d'aide. Lorsque j'exporte de mon logiciel MYOB (comptabilité) vers Excel, les nombre on un espace entre les milliers et je suis incapable de l'enlever automatiquement. Je dois enlever ces espace pour qu'Excel reconnaisse que c'est un nombre.

J'ai lu tout les trucs a propos de multiplication et le reste il y a rien qui marche, je suis pret a envoyer mon fichier a qui peut m'aider.

Merci bcp ...

Martin qui est un peu désespérer ...
 

Pièces jointes

  • Classeur1.xls
    15 KB · Affichages: 74
  • Classeur1.xls
    15 KB · Affichages: 74
  • Classeur1.xls
    15 KB · Affichages: 77
Dernière édition:

Denis132

XLDnaute Impliqué
Re : Probleme de format de cellulle

Bonsoir Martin et bienvenue sur le forum,

Essai cette formule en d1, puis recopie vers le bas et à droite:

=SI(GAUCHE(B1;1)="(";GAUCHE(B1;NBCAR(B1)-5)&DROITE(B1;3);GAUCHE(B1;NBCAR(B1)-4)&DROITE(B1;3))+0

@+

Denis
 
Dernière édition:

martin sthilaire

XLDnaute Nouveau
Re : Probleme de format de cellulle

Suite...

Voici le fichier complet... il semble que ca fonctionne pas en entier le truc, car j'ai des nombre de plus de 1 000 000 et ceux avec des bracquette ( ) ....

qu'est-ce que vous en pensez?
 

Pièces jointes

  • Classeur2.xls
    37 KB · Affichages: 52
  • Classeur2.xls
    37 KB · Affichages: 58
  • Classeur2.xls
    37 KB · Affichages: 57

Tibo

XLDnaute Barbatruc
Re : Probleme de format de cellulle

Bonjour Martin,

La formule proposée par Jacques Boisgontier me semble donner satisfaction dans tous les cas de figure, y compris les nombres entre parenthèses (ou bracquette ?)

Pour JHA, le fait d'avoir indiqué 1 en dernier paramètre de la fonction SUBSTITUE fait que seul le premier CAR(160) sera remplacé.

Si problème persiste, reviens avec plus de détails en nous décrivant précisément le problème rencontré.

@+
 

JHA

XLDnaute Barbatruc
Re : Probleme de format de cellulle

Bonjour Tibo,

J'ai essayé la formule de JB et les datas en parenthèses sont affichées en négatif.
Pour le 2ème espace, les 2 formules renvoient l'erreur #VALEUR!
A voir si cela convient à Martin.

JHA
 
Dernière édition:

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 885
Messages
2 093 259
Membres
105 660
dernier inscrit
moi46