Microsoft 365 mettre colonne sous forme de formule dans une autre formule

titooooo

XLDnaute Occasionnel
Bonjour

Bonjour je veut faire un fonction somme si mais mon tabkleau d'origine est très grand sans entete
je désire au lien de mettre moi-même la colone je la mets sous forme de recherche v

donc au lieu de mettre qu'il cherche dans la colonne S:S je lui met RECHERCHEV(F1;$D$22:$F$28;3;0):RECHERCHEV(F1;$D$22:$F$28;3;0)

car le résultat de RECHERCHEV(F1;$D$22:$F$28;3;0):RECHERCHEV(F1;$D$22:$F$28;3;0) cela donne S:S
 

Pièces jointes

  • test.xlsx
    14.6 KB · Affichages: 4

vgendron

XLDnaute Barbatruc
Bonjour

je ne comprend pas trop ce que tu veux remplir, où

ton tableau très grand;. c'est quoi ? M5:W10 ??
il peut y avoir plusieurs colonnes pour une meme journée (je vois une colonne pour Lundi, mais 2 pour Jeudi, et 3 pour vendredi.. est ce que les jours apparaissent une seule fois??)

une formule à base de équiv, décaler en haut à gauche
 

Pièces jointes

  • test (1).xlsx
    14.8 KB · Affichages: 1

titooooo

XLDnaute Occasionnel
Vraiment un grand merci à tous

juste une p'tite info j'ai opté pour cette formule mais le souci c'est que la base de recherche dans mon ficher se trouve sur une autre feuille

j'ai mis le tableau sur feuille 2

=SOMME.SI(M:M;A2;INDIRECT(RECHERCHEV(F1;$D$22:$F$28;3;0)&":"&RECHERCHEV(F1;$D$22:$F$28;3;0)))

merci d'avance
 

Pièces jointes

  • test (1).xlsx
    15.2 KB · Affichages: 3

Discussions similaires

Réponses
2
Affichages
284

Statistiques des forums

Discussions
313 277
Messages
2 096 762
Membres
106 744
dernier inscrit
Popies