XL 2016 Macro avec With End With

Bruce68

XLDnaute Impliqué
Bonsoir à tous
J' ai une macro sans With End With qui fonctionne et dés que je met With et end with ele ne fonctionne plus : erreur d exécution 1004
erreur définie par l'application ou par l'objet.
Voir fichier joint.
Je vous remercie de votre aide.
 

Pièces jointes

  • Macro avec et sans With End With.pdf
    273.4 KB · Affichages: 24

soan

XLDnaute Barbatruc
Inactif
@JBARBE

Tu as écrit :
« 0 affichage ne veut rien dire ( depuis le 26 Novembre 2008 que je suis inscrit )!
Tu devrais être au courant ! »

Merci pour ta réponse ; mais non : je n'étais pas au courant, et personne
ne m'en a parlé depuis mon inscription du 18 août 2020 ! :confused:

J'étais sûr que c'était le nombre de téléchargements ; alors comment
aurais-je pu savoir que « 0 affichage ne veut rien dire » ?

Comme tu es inscrit en 2008 et moi en 2020, tu as 12 ans d'avance
sur moi ! donc même si tu es blasé, c'est tout à fait normal que
tu en saches plus que moi !!!

Bonne nuit quand même !

soan
 
Dernière édition:

soan

XLDnaute Barbatruc
Inactif
@JBARBE

Si « 0 affichage ne veut rien dire » et que c'est un bug du site XLD,
je pouvais encore moins le savoir ! je ne suis pas extralucide pour
deviner qu'une telle fonctionnalité ne marche pas, et que c'est
à cause d'un bug du système ! :rolleyes:

soan
 
Dernière édition:

Bruce68

XLDnaute Impliqué
bonjour jbarbe et le forum
Merci jbarbe pour le nouveau code qui fonctionne.

.Range("C2").PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks:=False, Transpose:=False

Avec cette nouvelle ligne tout fonctionne comme je voulais, encore merci pour l'aide
 

Discussions similaires

Statistiques des forums

Discussions
302 248
Messages
2 001 848
Membres
215 340
dernier inscrit
Pietro Cavallo