Liste + validation + indirect [Résolu]

Usuule

XLDnaute Nouveau
Bonjour le forum,

Je suis bloqué et ne comprends pas pourquoi et ne trouve pas la solution.

L'objectif est à partir d'une base de donnée système de retenir les champs de la première ligne et d'avoir un liste de validation filtré des doublons et des cellules vides.
Je vous joins un fichier test et vous explique ci-dessous le principe et mon blocage.

La feuille BASE est ma base de donnée commençant en cellule D2.
Les colonnes A à C sont des champs calculés.
COLONNE B : incrémente le numéro pour tout nouveau compte (annulation des doublons)
COLONNE A : compteurs sur valeurs retenues en colonne B
COLONNE C : synthétise les numéros retenus en colonne B (suppression des vides)

La feuille TRAVAIL doit contenir la validation de données par liste.

J'ai créé deux noms pour essayer de faire fonctionner la validation de données et n'apparaissent que les 3 valeurs retenues dans la colonne C de la feuille BASE.

Mais rien ne fonctionne et je bloque à ce point.

J'espère avoir été assez clair et que vous pourrez m'aider.
 

Pièces jointes

  • test liste validation.xlsx
    12.6 KB · Affichages: 40
  • test liste validation.xlsx
    12.6 KB · Affichages: 44
  • test liste validation.xlsx
    12.6 KB · Affichages: 45
Dernière édition:

R@chid

XLDnaute Barbatruc
Re : Liste + validation + indirect

Bonjour,
Voir PJ si j'ai bien compris???
Amicalement
 

Pièces jointes

  • test liste validation.xlsx
    12.9 KB · Affichages: 43
  • test liste validation.xlsx
    12.9 KB · Affichages: 39
  • test liste validation.xlsx
    12.9 KB · Affichages: 43

Jocelyn

XLDnaute Barbatruc
Re : Liste + validation + indirect

Bonjour le Forum,
Bonjour Usuule,

Je ne suis pas bien sur d'avoir compris, selon tu voulais n'avoir dans ta liste de validation que les 3 donnée de la colonne, alors j'ai modifié la formule de la plage nommée test car nbval compte pour 1 une cellule contenant ""

Cordialement

EDIT : Bonjour R@chid :)
 

Pièces jointes

  • test liste validation.xls
    17 KB · Affichages: 43

R@chid

XLDnaute Barbatruc
Re : Liste + validation + indirect

Bonjour,
on peut faire la liste en colonne C sans les colonnes Intermédiaires A et B, je voie que tu ne veux pas peut etre trier les valeurs par Ordre Croissant ou Décroissant, tu veux garder peut être l’ordre d'apparition dans la colonne F, si c'est le cas,
sélectionner la plage C3:C43, et copier cette formule dans la barre de formule,
Code:
=SIERREUR(INDEX(F3:F43;PETITE.VALEUR(SI(LIGNE(INDIRECT("1:"&LIGNES(F3:F43)))=EQUIV(F3:F43;F3:F43;0);EQUIV(F3:F43;F3:F43;0));LIGNE(INDIRECT("1:"&LIGNES(F3:F43)))));"")
@ valider par Ctrl+Maj+Entree
@ micalement

Edit : Salut Jocelyn
 

Discussions similaires

Réponses
8
Affichages
502
Réponses
5
Affichages
209

Statistiques des forums

Discussions
312 848
Messages
2 092 786
Membres
105 534
dernier inscrit
EmilieG60