XL 2019 Joindre texte sauf si valeur = 0

sofmat

XLDnaute Junior
Bonjour, J'ai une problématique, je dois joindre un résultat de texte sauf si celui-ci comporte un zéro mais je ne trouve pas la solution.
Ma formule est : =SIERREUR(JOINDRE.TEXTE(" - ";VRAI;CS21:CU21);"") mais vue que mon tableau où se trouve CS21:CU21 comporte certaines fois des zéros, le résultat est 1 L - 0 TA - 0 LTA alors je voudrai qu'il affiche 1 L car les autres données sont à zéro.

Quelqu'un pourrait m'aider ? Merci beaucoup.
 

Pièces jointes

  • concatener.xlsx
    30.9 KB · Affichages: 5

Cousinhub

XLDnaute Barbatruc
Inactif
Bonjour,
C'est dans le Tableau 2 qu'il faut modifier tes formules...
A la place des différents SI(ESTVIDE(BK20)..., tu mets :
VB:
=SI(BK20=0;"";CONCATENER(BK20;" L";""))
Et ceci pour toutes les cellules concernées dans le Tableau2

Edit, bonjour chris, plus rapide (mais pas la même solution... :) )
 

Discussions similaires

Statistiques des forums

Discussions
313 283
Messages
2 096 813
Membres
106 752
dernier inscrit
Tahiri1976