Heures superieres a 24h00 et format [hh]:mn

atlonia

XLDnaute Occasionnel
Heures superieres a 24h00 et format [hh]:mn[Resolu]

Hello tout le monde,

J'ai lu que pour afficher les heures supérieures à 24h00 il fallait mettre le format cellule à [hh]:mn, malgré ça, excel s'évertue a continuer à ne pas me les afficher...!

Quelqu'un a-t-il la solution?

De plus j'ai en feuil3 Cellule B2 j'ai une formule SOMMEPROD qui me calcul le total des heures sup et qui ne sait pas calculer les heures négatives...!

Auriez vous une idée à ce sujet?

Ci joint, mon classeur:
 

Pièces jointes

  • horaires05v04b(recup semaines)effaceR7aR41matricielle.zip
    21.4 KB · Affichages: 37
  • horaires05v04b(recup semaines)effaceR7aR41matricielle.zip
    21.4 KB · Affichages: 34
  • horaires05v04b(recup semaines)effaceR7aR41matricielle.zip
    21.4 KB · Affichages: 36
Dernière édition:

Monique

Nous a quitté
Repose en paix
Re : Heures superieres a 24h00 et format [hh]:mn

Bonjour,

Dans cette formule, il faut les deux [ ]
et on peut la raccourcir
=SI(Q7=0;0;SI(Q7>P7;Q7-P7;"-"&TEXTE(P7-Q7;"[hh]:mm")))

Elle renvoie du texte si P7>Q7
et une valeur numérique si Q7>P7

Pour faire ensuite des calculs sur le texte, c'est plutôt compliqué mais c'est faisable.
Il vaut mieux passer au calendrier depuis 1904
dans Outils - Options - Calcul et cocher "Calendrier depuis 1904"

Sauf que… ton classeur est déjà au calendrier depuis 1904 ! !
donc en R7, tu mets simplement
=Q7-P7
avec le même format [hh]:mm

SommeProd en feuille 3 : pas vu.
 

atlonia

XLDnaute Occasionnel
Re : Heures superieres a 24h00 et format [hh]:mn

Bonsoir Wilfried et Monique,

Merci pour votre aide!

Wilfried, je n'ai pas dû bien comprendre le format "date", j'ai fait un essai, et ça m'affiche une date a la place des heures!

Monique, ta solution a réglé mon problème.

Merci encore a tout les deux pour votre aide...!
 

Discussions similaires

Statistiques des forums

Discussions
312 113
Messages
2 085 420
Membres
102 886
dernier inscrit
eurlece