Formule Si Ou

maval

XLDnaute Barbatruc
Bonsoir


je cherche une formule que je ne trouve pas sur les post

je souhaiterai trouver une formule qui réunisse plusieurs condition dont le OU et le SI

je voudrai que dans une cellule "O" additionne Q6 * 20 et R6 *252 et si les cellule Q6 Ou Et R6 son vide la cellule "O" reste vide.

Voici ma formule
Code:
=SI(OU(Q6="");"";Q6*20);SI(OU(R6="");"";R6*252)

D'avance merci à qui pourra m'aider.
Cordialement

Maval
 

maval

XLDnaute Barbatruc
Re : Formule Si Ou

Bonjour Denis132, R@chid,

Je vous remercie de votre aide je vous joint mon exemple.

La formule doit faire ceci,
si dans l'une des deux validations de données il n'y a rien, on devrai avoir le résultat de l'autre?
Si dans les deux validations de données il y a rien on a rien.

Merci de votre aide et bonne journée

Max
 

Pièces jointes

  • Formule.xlsm
    12 KB · Affichages: 25
  • Formule.xlsm
    12 KB · Affichages: 28
  • Formule.xlsm
    12 KB · Affichages: 30

maval

XLDnaute Barbatruc
Re : Formule Si Ou

Bonjour vgendron

Merci de ton code mais:
si il y a les deux résultat additionner les deux
si une des deux et vide mettre le résultat de celle qui a un Nbre
si les deux son vide ne rien mettre

Pas évident d'expliquer?

@+
Max
 

maval

XLDnaute Barbatruc
Re : Formule Si Ou

Re

Non? mais presque
si il y a les deux résultat; additionner les deux le premier et a multiplier par 20 et l'autre par 252
exemple: si dans le premier il y a 3 et le deuxième il y a 2 =3 x 20 + 2 x 252 soit 564
si dans le premier il y a 3 et le deuxième il y a "" =3 x 20 soit 60
si les deux son vide "" ne rien mettre
si dans le premier il y a "" et le deuxième il y a "" soit """ rien

@+
Max
 

vgendron

XLDnaute Barbatruc
Re : Formule Si Ou

alors. on va y arriver..
=SI(ET(Q7="";R7="");"";SI(Q7="";20*R7;SI(R7="";20*Q7;20*Q7+ 2*R7)))

pour décomposer cette formule,
si les deux sont vides alors rien : si (ET(Q7="";R7="");"";
sinon
si le premier est vide alors deuxième*20: SI(Q7="";20*R7;
sinon
si le second est vide alors Premier*20 SI(R7="";20*Q7;
sinon
les deux sont remplis: 20*Premier + 2 * Second: 20*Q7+ 2*R7)))
 

maval

XLDnaute Barbatruc
Re : Formule Si Ou

Re,

Oui serrai était beaucoup plus simple mais je voulais que s'il n'y avait aucune valeur dans les validations
le résultat était "" voila

Mais comme ont dit chez moi pourquoi faire simple quand on peut faire compliquer:eek:

@+
ax
 

Discussions similaires

  • Résolu(e)
Microsoft 365 Formule SI
Réponses
8
Affichages
267
Réponses
2
Affichages
164

Statistiques des forums

Discussions
312 931
Messages
2 093 721
Membres
105 796
dernier inscrit
Max...26