XL 2019 Formule qui va chercher une date dans mon planning

Lionel69890

XLDnaute Junior
Bonjour à tous,

Je sèche complet sur une formule que je dois insérer dans mon tableau pour aller chercher la première date de passage à partir d'aujourd'hui.
La formule doit renvoyer la date sur la ligne 6 qui correspond au premier x affiché à partir d'aujourd'hui (inclus)

cf. fichier joint c'est plus parlant

Merci d'avance de votre aide
 

Lionel69890

XLDnaute Junior
Hello

une solution par formule matricielle en P7


tu valides la formule avec Ctrl+Mal+Entrée==> des accolades apparaissent
et tu tires la formule vers le bas

Merci d'avance pour ton aide mais ta formule prend la date (avant aujourd'hui) alors qu'elle devrait renvoye r le 24/01

1674207384285.png
 

Cousinhub

XLDnaute Barbatruc
Bonjour,
Essaie ainsi (en P7, à tirer vers le bas)
VB:
=SIERREUR(DECALER($P$2;4;EQUIV("x";DECALER($P$2;LIGNE()-2;EQUIV($F$4;$Q$2:$BT$2;0);1;5);0));"")
Bonne journée
Edit :
Un poil plus court
Code:
=SIERREUR(DECALER($P$2;4;EQUIV("x";DECALER($Q7;;EQUIV($F$4;$Q$2:$BT$2;0);1;5);0))+1;"")
Edit2: Bah non, oublié le "à partir d'aujourd'hui"...
 
Dernière édition:

Discussions similaires

Réponses
0
Affichages
317

Statistiques des forums

Discussions
313 274
Messages
2 096 750
Membres
106 738
dernier inscrit
Lacbus