Microsoft 365 Formule pour remettre sur d'autres feuilles

Virginie31p

XLDnaute Nouveau
Bonjour,
Avec mon travail, nous sommes amenées a établir une prévision de sortie pour nos patients.
Le forum Excel m'avait bien aidé pour répartir ma prévision en fonction des Médecins (au vu de la formule, elle était très complexe).
Aujourd'hui j'ai du rajouter une colonne.

Je souhaiterai donc dans l'onglet "prévi" qu'il y a une formule dans la colonne G
La formule est de reprendre dans les onglets "ext" + "anc bat" la colonne A - en fonction des chambres.

Est ce possible de m'aider ?

Merci d'avance.
 

Pièces jointes

  • prévi ok avec 4e nvlle org° - 01.11.21- Copie - Copie.xlsx
    170.9 KB · Affichages: 2

JHA

XLDnaute Barbatruc
Bonjour à tous,

Pas certain de tout comprendre.
Formule matricielle à essayer
VB:
=SIERREUR(INDEX(ext!$A$2:$A$30;EQUIV($A2&$C2;ext!$C$2:$C$30&ext!$F$2:$F$30;0));INDEX('Anc bat'!$A$2:$A$70;EQUIV($A2&$C2;'Anc bat'!$C$2:$C$70&'Anc bat'!$F$2:$F$70;0)))

On regarde si on trouve la chambre et le patient dans l'onglet "ext" et on retourne la valeur de la colonne "A" de cet onglet.
Si la chambre et le patient ne sont pas trouvés dans cet onglet, on regarde la même chose dans l'onglet "Anc bat" puis on retourne la valeur de la colonne "A".

JHA
 

Pièces jointes

  • prévi ok avec 4e nvlle org° - 01.11.21- Copie - Copie.xlsx
    174.4 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
313 277
Messages
2 096 765
Membres
106 746
dernier inscrit
acquabateaux