XL 2016 Formule nbre de jours ouvrés et cellules vides renvoyant la cellule O à vide

HE_RA

XLDnaute Nouveau
Bonjour à tous,

Ma cellule "O13" contient la formule suivante =NB.JOURS.OUVRES.INTL(J13;K13;"0000000")-SI(L13+M13=1;0;L13+M13) qui renvoie le résultat du nombre jour pris "J13" début date et "M13" date fin ayant pour condition une absence d'une demi-journée en "L13" matin et "M13" pour l'après-midi. Quand les cellules "J13" et "M13" sont vide, avec la formule que j'ai intégré dans la cellule "O13" m'affiche le résultat.
J'aimerai que "O13" reste vide.

SVP, je vous remercie pour aide 🙏.
 

HE_RA

XLDnaute Nouveau
Bonsoir,
VB:
=SI(L13&M13="";"";NB.JOURS.OUVRES.INTL(J13;K13;"0000000")-SI(L13+M13=1;0;L13+M13))
Cordialement,
Bonjour Gégé, tes corrections ont fonctionnées. Mais j'ai oublié de préciser que j'ai une autre cellule qui m'affiche ceci #VALEUR! qui se trouve être dans la cellule "S13". Cette cellule correspond à la soustraction de "O13" moins (-) "R13". La cellule "S13" contient cette formule suivant : =SI(R13-O13="";"";R13-O13) mais cela ne marche pas.
Merci pour ton retour
 

Gégé-45550

XLDnaute Accro
Bonjour Gégé, tes corrections ont fonctionnées. Mais j'ai oublié de préciser que j'ai une autre cellule qui m'affiche ceci #VALEUR! qui se trouve être dans la cellule "S13". Cette cellule correspond à la soustraction de "O13" moins (-) "R13". La cellule "S13" contient cette formule suivant : =SI(R13-O13="";"";R13-O13) mais cela ne marche pas.
Merci pour ton retour
Bonsoir,
si S13 affiche #VALEUR!, cela signifie qu'au moins une des deux cellules R13 ou O13 contient autre chose qu'une valeur numérique ou rien.
Deux possibilités sont alors possibles :
  • soit c'est une erreur et il convient de corriger le contenu erroné (dans O13, R13 ou les deux)
  • soit c'est normal et dans ce cas, pour éviter l'affichage de l'erreur #VALEUR!, il est possible de remplacer la formule
    Code:
    =SI(R13-O13="";"";R13-O13)
    par celle-ci :
    VB:
    =SI(ESTERREUR(R13-O13);"";R13-O13)
Cordialement,
 

Statistiques des forums

Discussions
312 935
Messages
2 093 737
Membres
105 803
dernier inscrit
metroMBP